Installing Alfresco 2.1 on Ubuntu 7.10 (Talk)

Document created by derek Employee on Aug 12, 2009
Version 1Show Document
  • View in full screen mode

Couple of remarks:

- The useradd doesn't create a group, so the chown a bit further fails
- you seem to be running alfresco as user alfresco, and to change the ports it binds to for samba/nfs etc so that it doesn't need root to; this probably requires to configure the samba/ftp config files to change the port it connects to.



Else:

 WONDERFUL JOB! I've been looking for exactly that for sooo long. Thank you so much.

Java-line


Since the Java version changes (mine is currently 1.6.0.03, while the document says 1.6.0.00), you should use the symbolic link instead, which is java-6-sun


Problems with logging


I updated the page somewhat, fixing some problems noted by other commenters.
There seem to be a problem with the section 'Configure logging': there is no log4j.properties in tomcat/webapps/alfresco/WEB-INF/classes/ (there actually is no tomcat/webapps/alfresco/WEB-INF/classes/ directory; the only items in tomcat/webapps/ are alfresco.war and directory ROOT).
But there is log4j.properties in tomcat/work/Catalina/localhost/alfresco/WEB-INF/classes/, which seems to be the right file to edit


Problems with init script


I suggest to use the -E option for the sudo commands to pass the environments variables to the tomcat scripts


No Browser on Localhost


First, THANK YOU! Second, everything went swimmingly until the very last line in your directions: 'After starting alfresco, point your browser at to http://localhost:8080/alfresco'

I don't have a GUI on my server. It is a VPS and I haven't figured out how to install Gnome. To access Alfresco I tried 'http://mydomain.com:8080/alfresco' from my desktop browser with no luck. I'm in over my head. Broadpath 00:10, 20 November 2008 (UTC)

Attachments

    Outcomes