Debian Installation (Talk)

Document created by arkaitz on Nov 21, 2008
Version 1Show Document
  • View in full screen mode

Hello!

I have followed the instructions for installing alfresco on a Debian system.

Debian installation is the same that used in the tutorial, and alfresco file is alfresco-labs-tomcat-3b.tar.gz .

After follow all the steps until 'Optional: Installing extra modules/packages'  I tried to launch my alfresco and in the login page I insert user:admin and pass:admin and I have an error message like this: 'Failed to login: The remote server may be unavailable or your authentication details have not been recognised'.

Before I intalled Debian on my server, I tried to do the alfresco installation twice on a CentOs 5.1 and CentOs 5.2 server system, and after follow differents ways on installation, I always obtain the same answer, a login error.

Does anyone know why can be that?

Thank you.

Mrogers 14:19, 21 November 2008 (UTC) Some discussion forums point out that its necessary to wait a while (for the indexes to build) before the admin account can be found.  Are you overly eager to log in, wait paitently for a few minutes and then try again?   Also are there any errors in your Alfresco log file?



ArkaitzLandaberea
Hello! First sorry for my english! ;)

Yes, there are some errors in alfresco.log. It says:

15:20:45,018 ERROR [org.apache.catalina.core.ContainerBase.[Catalina].[localhost]./alfresco] Exception sending context initialized event to listener instance of class org.alfresco.web.app.ContextListener
org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'luceneIndexBackupComponent' defined in class path resource [alfresco/core-services-context.xml]: Invocation of init method $
Caused by: org.springframework.transaction.CannotCreateTransactionException: Could not open Hibernate Session for transaction; nested exception is org.hibernate.exception.GenericJDBCException: Cannot open connec$
Caused by: org.hibernate.exception.GenericJDBCException: Cannot open connection
at org.hibernate.exception.SQLStateConverter.handledNonSpecificException(SQLStateConverter.java:103)
...



I have read in other forums that I have to wait a couple of minutes, but I wait more tan 2 or 3 minutes. When I try to open alfresco, the login page loads but when insertin login info it shows that message

Mrogers 15:41, 21 November 2008 (UTC) I have no problems understand your English 8-)
It looks like there's a database problem which needs fixing.  If double checking your database your database settings does not reveal a problem then I suggest you take this problem to the discussion forums, not many people will see this discussion on the wiki.  I think its unlikely to be due to 'debian installation.'

ArkaitzLandaberea

Ok! you're right. I will explain my problem in the forums.  However, thank you very much for your responses.





ArkaitzLandaberea

The last thing, and if with this I solve the problem I will explain the solution on a forum.

I have seen that when I create the database I must use db_setup.sql file, but this file only creates a database called alfresco and sets privileges up to an user named alfresco. But with this in really there is not any table in the database. Is this ok? Should the .slq file be wrong?

Mrogers 16:20, 21 November 2008 (UTC) When Alfresco starts up it will install (or update) the schema.   It just needs the empty schema to be start with.



ArkaitzLandaberea
Ok! Thank you again!

I will follow looking for the solution on the forums.

Attachments

    Outcomes