Mounting Local Alfresco CIFS Share On OS X

Document created by resplin Employee on Jun 6, 2015
Version 1Show Document
  • View in full screen mode

Obsolete Pages{{Obsolete}}

The official documentation is at: http://docs.alfresco.com



OS X Finder, from version 10.5 forward, will not allow you to mount local CIFS shares. For example, if you are running Alfresco on your Mac and you want to mount a CIFS share from this instance of Alfresco, it with return a Connection failed error: 'This file server is running on your local machine. Please access the volumes and files locally.'

You can mount the drive locally, but you need remove Finder from the equation.


Pre-Requisites


These instructions assume you're running Alfresco as a root user:


$ sudo alfresco.sh start

Alternatively, you've enabled port forwarding as per: Installing on MacOS X


Steps


To mount the share locally:

1. Choose/create a mount point. This can be done in Finder or from the command line. From the command line, type:

mkdir ~/mount_point

2. Use mount_smbfs from the command line to mount the share:

mount_smbfs //username:password@localhost/alfresco ~/mount_point

Troubleshooting


Q: When I try to mount the share, I get: mount_smbfs: mount error: /some/path: Unknown error: -1

A: Your mount point should be readable and writable by you. If you created the mount point in finder this should already be done for you. If you created the mount point from the command line and you do not own the directory:

chown username:group ~/alfresco

Q: I am unable to mount the share locally, but I can mount it on other machines.

A: If you are using port forwarding, your rule for localhost connections may not be forwarding these connections correctly. Try connecting using

mount_smbfs //username:password@localhost:port/alfresco ~/mount_point 

where port is equal to the port that the Alfresco server is listening for connections. If it connects, your port forwarding rules for localhost are incorrect.

Q: I've tried everything. I am not sure if my request is even making it to Alfresco, or, none of these troubleshooting tips helped.

A: Turn on debug. Debug can be enabled in WEB-INF/classes/log4j.properties.

Change error to debug and uncomment the other directives.

log4j.logger.org.alfresco.smb.protocol=error
#log4j.logger.org.alfresco.smb.protocol.auth=debug
#log4j.logger.org.alfresco.acegi=debug

CIFS
Mac OS X

Attachments

    Outcomes