AnsweredAssumed Answered

Problema al iniciar Alfresco ACS Community con Docker

Question asked by rublape on Apr 26, 2019
Latest reply on May 2, 2019 by angelborroy

Buenas tardes,

 

Estoy desplegando la última versión de Alfresco Community con Docker y estoy teniendo problemas al iniciar sesión en Share.

 

He desplegado las imágenes community con docker-compose (adjunto el archivo YAML) y se descargan todas las imágenes correctamente, se ejecutan los contenedores (parece que correctamente) pero al final aparece el siguiente error:

share_1        |  2019-04-26 12:00:34,150  INFO  [web.site.EditionInterceptor] [http-nio-8080-exec-2] Unable to retrieve License information from Alfresco: 404

 

Cuando esto ocurre entro a SHARE y cuando intento entrar con las credenciales por defecto (admin/admin) me aparece el error "No se han reconocido sus datos de autenticación o puede que Alfresco Content Services no esté disponible en este momento"  adjunto imagen.

 

Revisando los logs veo que la base de datos postgre se conecta correctamente a alfresco por lo que he descartado el problema con la BBDD.

 

La única forma que he conseguido que arranque alfresco correctamente y pudiendo entrar a SHARE es eliminando los volúmenes, el problema es que me quedo sin persistencia de datos :-(

Cuando arranca sin volúmenes aparece el mensaje que la licencia se ha cargado correctamente.

 

¿Sabéis cual puede ser la causa por la que no carga correctamente alfresco cuando configuro volúmenes?

 

Mi despliegue es el siguiente:

- Sitema Operativo: PhotonOS (Basado en Centos) instalado en VM ESX

- CPU: 1 CPU / 2vCores

-Memoria: 16 GB

-Docker Version: 

  Client:
      Version: 18.06.2
      API version: 1.38
      Go version: go1.10.7
      Git commit: 6d37f41
      Built: Mon Feb 25 14:49:01 2019
      OS/Arch: linux/amd64
      Experimental: false

Server:
   Engine:
   Version: 18.06.2-ce
   API version: 1.38 (minimum version 1.12)
   Go version: go1.10.7
   Git commit: 6d37f41
   Built: Mon Feb 25 14:54:48 2019
   OS/Arch: linux/amd64
   Experimental: false

 

- docker-compose version

      docker-compose version 1.24.0, build 0aa59064
      docker-py version: 3.7.2
      CPython version: 3.6.8
      OpenSSL version: OpenSSL 1.1.0j 20 Nov 2018

 

 

Para hacer esto he seguido varias guías, entre ellas:

Deploying and Running Alfresco Content Services 6.0 

- GitHub - Alfresco/acs-community-deployment: Deployment descriptors pull together Alfresco Content Services (Community) 

https://community.alfresco.com/community/ecm/blog/2018/05/01/using-alfresco-201804-ea-in-a-simple-prod-environment

-https://github.com/keensoft/alfresco-docker-template/tree/master/templates/201804-EA

-https://github.com/keensoft/docker-alfresco/blob/master/docker-compose.yml 

 

y alguna que otra...pero consiguiendo los mismos resultados...

 

También he clonado el proyecto de GIT https://github.com/keensoft/docker-alfresco para que se instalara todo correctamente y pasa lo mismo... Todo se lanza correctamente pero a la hora de acceder a SHARE aparece el error que adjunto.

 

He probado de todo y ya me he vuelto medio loco, ¿alguna idea?

 

Gracias por adelantado.

Attachments

Outcomes