AnsweredAssumed Answered

Problems importing content

Question asked by hsjawanda on Nov 2, 2005
Latest reply on Nov 5, 2005 by davidc

I have defined my own content model that is complementary to Alfresco's content model.  Most of the content model works fine.  However, it seems that a cm:folder -like type that I have defined (called cms:folder) can only contain cm:content, not my own version of cm:content (called cms:asset).

("cm" being the namespace for Alfresco's content model, "cms" being my own (yeah, not very imaginative, I know :) ))

This problem occurred when trying to bootstrap through ImporterBootstrap. I get an exception that basically says the entity contained within my cms:folder has to be of type cm:content.  Even when I try to derive my cms:asset from cm:content, I get the error message.  Temporarily, I've had to go back to using cm:content instead of cms:asset.

Could there be some hard-coded checking somewhere?  Any help would be highly appreciated.  Please do ask for clarification(s) if I've not been clear.  Thanks.

Here's my content model, wherein I've interspersed some comments for this post:

<model name="cms:contentmodel" xmlns="">

    <description>F1 CMS Content Model</description>

        <import uri="" prefix="d"/>
        <import uri="" prefix="sys"/>
        <import uri="" prefix="cm"/>

        <namespace uri="" prefix="cms"/>

        <type name="cms:object">

        <type name="cms:container">
                <child-association name="cms:contains">
                        <class>cm:cmobject</class> <!– This would've been cms:object –>

        <type name="cms:project">

        <type name="cms:folder">

        <!–type name="cms:asset"> <!– My failed attempt to derive from cm:content. The derivation works, but not the import –>
        <!– cms:asset is exactly analogous to cm:content, except that the auditable
             aspect has been made mandatory.
        <type name="cms:asset">  <!– The original definition –>
                <property name="cm:contentUrl">
                    <index enabled="true">
                <property name="cm:mimetype">
                <property name="cm:encoding">
                <property name="cm:size">