AnsweredAssumed Answered

CIFS error under Linux on Alfresco V1

Question asked by lgr on Nov 3, 2005
Latest reply on Nov 4, 2005 by crtx
Hello,

I'm installing Alfresco under Linux Debian. I've got a problem with the CIFS share.
When there is no DOMAIN defined in file-servers.xml, CIFS does not start at all (but alfresco works). When i define any DOMAIN in the XML file, CIFS starts with these errors (i've set all SMB protocol logging to debug).

Here are the errors :

16:08:53,460 INFO  [org.alfresco.smb.protocol] [SMB] SMB Server NULL_A starting
16:08:53,460 INFO  [org.alfresco.smb.protocol] [SMB] Version 3.5.1
16:08:53,460 INFO  [org.alfresco.smb.protocol] [SMB] Java VM 1.5.0_05-b05
16:08:53,460 INFO  [org.alfresco.smb.protocol] [SMB] OS Linux, version 2.6.8-2-686
16:08:53,460 INFO  [org.alfresco.smb.protocol] [SMB] Using authenticator org.alfresco.filesys.server.auth.AlfrescoAuthenticator, mode=USER
16:08:53,460 INFO  [org.alfresco.smb.protocol] [SMB] No user accounts defined
16:08:53,461 INFO  [org.alfresco.smb.protocol] [SMB] Server timezone Europe/Paris, offset from UTC = -1hrs
16:08:53,461 INFO  [org.alfresco.smb.protocol] [SMB] Shares:
16:08:53,468 ERROR [org.alfresco.smb.protocol.netbios] NetBIOSNameServer setup error:
java.net.UnknownHostException: alfresco: alfresco
        at java.net.InetAddress.getLocalHost(InetAddress.java:1308)
        at org.alfresco.filesys.netbios.server.NetBIOSNameServer.run(NetBIOSNameServer.java:1473)
        at java.lang.Thread.run(Thread.java:595)
16:08:53,495 INFO  [org.alfresco.smb.protocol] [SMB]  [Alfresco,DISK,,[workspace://SpacesStore/34f8b891-4c79-11da-9112-c51dfd20e189]] [workspace://SpacesStore/34f8b891-4c79-11da-9112-c51dfd20e189]
16:08:53,523 INFO  [org.alfresco.smb.protocol] [SMB] Add Share [IPC$,IPC$,,Admin,Hidden] : true
16:08:53,540 DEBUG [org.alfresco.smb.protocol] [SMB] Binding NetBIOS session handler to local address : ALL
16:08:53,752 DEBUG [org.alfresco.smb.protocol] [SMB] TCP NetBIOS session handler created
16:08:53,762 DEBUG [org.alfresco.smb.protocol] [SMB] TCP NetBIOS host announcer created
16:08:53,767 DEBUG [org.alfresco.smb.protocol] [SMB] Binding TCP-SMB session handler to local address : ALL
16:08:53,768 DEBUG [org.alfresco.smb.protocol] [SMB] Native SMB TCP session handler created
16:08:53,799 DEBUG [org.alfresco.smb.protocol] [SMB] Waiting for NetBIOS session request …
16:08:53,812 DEBUG [org.alfresco.smb.protocol] [SMB] Waiting for TCP-SMB session request …
16:08:53,815 ERROR [org.alfresco.smb.protocol.mailslot] HostAnnouncer error
java.net.UnknownHostException: alfresco: alfresco
        at java.net.InetAddress.getLocalHost(InetAddress.java:1308)
        at org.alfresco.filesys.netbios.NetBIOSDatagram.SendDatagram(NetBIOSDatagram.java:415)
        at org.alfresco.filesys.smb.mailslot.TcpipNetBIOSHostAnnouncer.sendAnnouncement(TcpipNetBIOSHostAnnouncer.java:204)
        at org.alfresco.filesys.smb.mailslot.HostAnnouncer.run(HostAnnouncer.java:288)
16:08:54,445 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community Network) - v1.0.0; repository v1.0.0


—–
Anyway, when i add the Alfresco linux box address in my lmhosts file, i can access the share, using the name defined in the lmhosts, not the name_A (i'm not sure if this normal or not).

If anyone can help me debug that …

Thanks a lot,

Laurent.

Outcomes