AnsweredAssumed Answered

Problem with the association control?

Question asked by rdanner on Nov 11, 2005
Latest reply on Nov 11, 2005 by rdanner
Is there a problem with the association control?
I re-bootstrapped my repository to make sure it was clean.
Re added my document to make sure that was clean
Re applied my aspect to make sure that was clean

but if I add an aspect like:

      <aspect name="cm:validXmlDocument">
         <title>Valid XML Document</title>

          <associations>
            <association name="cm:xmlSchema">
               <title>Xml Schema or DTD</title>
               <source>
                  <mandatory>false</mandatory>
                  <many>false</many>
               </source>
               <target>
                  <class>cm:content</class>
                  <mandatory>false</mandatory>
                  <many>false</many>
               </target>
            </association>
         </associations>
      </aspect>


Everything is cool except when the gadget renders in the UI for the association and I click "search" on the seach for and select items I am getting:


javax.faces.FacesException: Node does not exist: workspace://SpacesStore/19ab0723-4e2b-11da-9191-ed55789b8c24

caused by:
org.apache.jasper.JasperException: Node does not exist: workspace://SpacesStore/19ab0723-4e2b-11da-9191-ed55789b8c24

caused by:
org.alfresco.service.cmr.repository.InvalidNodeRefException: Node does not exist: workspace://SpacesStore/19ab0723-4e2b-11da-9191-ed55789b8c24

There is no GUID in the database with the ID 19ab0723-4e2b-11da-9191-ed55789b8c24

This control also failes when looking at the templatable aspect

Outcomes