AnsweredAssumed Answered

Charset & encoding through CIFS / Webdav / FTP...

Question asked by jgoffinet on Nov 28, 2005
Latest reply on May 9, 2007 by alexandra
Hi,

I've made some tests through several protocols. Here is the config I used:

- server: linux (debian) / mysql / tomcat bundle (1.0.0 release) - no special config

- client: WinXP Pro SP2 with :
   * Windows Explorer to access CIFS share
   * Windows Explorer with network places to access Webdav
   * Windows Explorer with network places to access FTP
   * DavExplorer to access webdav
   * FileZilla to access FTP

Here are the results of my investigations:

1. I had no success in connecting to FTP with FileZilla. Here is the log on the client side (no log on the server side but a java.net.ConnectException: Connection timed out):

– beginning of log
PORT 192,168,1,113,6,173
Réponse :   200 Port OK
Commande :   LIST
Réponse :   150 File status okay, about to open data connection
Erreur :   Inactivité détectée !
Erreur :   N'a pas pu récupérer la liste du répertoire
– end of log

(the 2 last lines mean: "inactivity detected" and "couldn't retrieve directory list").

2. Everything worked fine otherwise… until I tried to create spaces with accents in their names. I created the followings:
- "cifs-é" with Win Explorer
- "webdav-é" with network place
- "ftp-é" with network place
- "davexplo-é" with dav explorer
- "web-é" with web client
and looked at the result in the different clients.

3. CIFS, Web client, DavExplorer: for spaces created with CIFS, web client and DavExplorer, there seems to be no problem: space names are shown correctly, and it is possible to browse into them.

4. FTP (through network place): the folder "ftp-é" is shown as "ftp-?" in every client, even the one which was used to create it. It is impossible to browse into it through Network place. It is browsable only via web client and dav explorer (even if it is displayed as ftp-?). cifs-é, web-é, etc. are also shown as cifs-?, web-?, etc and are not browsable through FTP network place.

5. Webdav (through network place): the folder "webdav-é" is shown as webdav-é in every client (network place, cifs share, web client, dav explorer),but it is possible to browse into it. Other folders are shown correctly (cifs-é, web-é, etc.) but trying to access them leads to an error (folder unavailable).

Did anyone else encounter such troubles with accentuated files ?

Jean

Outcomes