AnsweredAssumed Answered

Alfresco on debian sarge: could not start app :-(

Question asked by pss on Dec 9, 2005
Latest reply on Dec 10, 2005 by pss
Hi :-)

I tried to install Alfresco on a debian sarge machine.

tomcat 5.5 manager tells me, that he can not start alfresco..(without any further error message)


the log files show something like this:
INFO: The Apache Portable Runtime which allows optimal performance in production environments was not found on the java.library.path: /opt/jdk1.5.0_06/jre/lib/i386/cli
ent:/opt/jdk1.5.0_06/jre/lib/i386:/opt/jdk1.5.0_06/jre/../lib/i386
Dec 9, 2005 9:55:55 PM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
Dec 9, 2005 9:55:55 PM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1112 ms
Dec 9, 2005 9:55:55 PM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Dec 9, 2005 9:55:55 PM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.12
Dec 9, 2005 9:55:55 PM org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
Dec 9, 2005 9:55:56 PM org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive alfresco.war
Dec 9, 2005 9:56:04 PM net.sf.joott.uno.UnoConnection connect
INFO: connecting using "socket,host=localhost,port=8100,tcpNoDelay=1"…
Dec 9, 2005 9:56:04 PM net.sf.joott.uno.UnoConnection connect
SEVERE: connection failed: com.sun.star.connection.NoConnectException: java.net.ConnectException: Connection refused
Dec 9, 2005 9:56:05 PM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Dec 9, 2005 9:56:05 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/alfresco] startup failed due to previous errors
Dec 9, 2005 9:56:05 PM org.apache.coyote.http11.Http11BaseProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
Dec 9, 2005 9:56:06 PM org.apache.jk.common.ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0.0:8009
Dec 9, 2005 9:56:06 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=0/30  config=null
Dec 9, 2005 9:56:06 PM org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
Dec 9, 2005 9:56:06 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 11524 ms

port 8100 is not used by any other aplication.

maybe someone may give me a hint :-)

Outcomes