AnsweredAssumed Answered

UnsupportedClassVersionError

Question asked by jeko on Jan 9, 2006
Latest reply on Aug 22, 2007 by simon
When I copied the alfresco war to my Tomcat (5.0) and started Tomcat I got the following error:

java.lang.UnsupportedClassVersionError: org/alfresco/web/app/ContextListener (Unsupported major.minor version 49.0)
   at java.lang.ClassLoader.defineClass0(Native Method)
   at java.lang.ClassLoader.defineClass(ClassLoader.java:537)
   at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
   at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:1634)
   at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:860)
   at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1307)
   at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1189)
   at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3775)
   at org.apache.catalina.core.StandardContext.start(StandardContext.java:4343)
   at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:823)
   at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:807)
   at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:595)
   at org.apache.catalina.core.StandardHostDeployer.install(StandardHostDeployer.java:277)
   at org.apache.catalina.core.StandardHost.install(StandardHost.java:832)
   at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:625)
   at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:431)
   at org.apache.catalina.startup.HostConfig.start(HostConfig.java:983)
   at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:349)
   at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:119)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1091)
   at org.apache.catalina.core.StandardHost.start(StandardHost.java:789)
   at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1083)
   at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:478)
   at org.apache.catalina.core.StandardService.start(StandardService.java:480)
   at org.apache.catalina.core.StandardServer.start(StandardServer.java:2313)
   at org.apache.catalina.startup.Catalina.start(Catalina.java:556)
   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
   at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
   at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
   at java.lang.reflect.Method.invoke(Method.java:324)

I don't understand this message, because there is only one jar (web-client.jar) that contains this class. Can someone help me with this one?


Thanks
Jeroen

Outcomes