AnsweredAssumed Answered

alfresco 1.1.2 on jboss-4.0.3SP1

Question asked by akashs on Jan 10, 2006
Latest reply on Jan 12, 2006 by kevinr
I am trying to deploy alfresco-war-1.1.2 (not from alfresco-jboss bundle) on jboss-4.0.3SP1 & jboss-4.0.2. I tried the following steps:

1) downloaded the jboss jboss-4.0.3SP1 & alfresco-war-1.1.2.
2) pasted the alfresco-war-1.1.2 in jboss-4.0.3SP1\server\default\deploy
    folder.
3) ran the jboss server & got the deployment fail error.

Then I tried following two things:

i) copied  (from alfresco-jboss bundle v1.1.2)
   <alfresco>/jboss/server/default/conf/alfresco/*.*  into
   <jboss>/server/default/conf/alfresco

   Ran the server & no luck

ii) In addition to above I did the following things as suggested in
    http://alfresco.org/forums/viewtopic.php?t=582&sid=95f7aa1704654a02c961963231d2df0d

    1. Downloaded the nightly build alfresco-src-06012006.zip.

    2. Changed the default target to "build-jboss" in the build.xml file in the 
        folder \alfresco-src-06012006\common\ and executed the ant build.

    3. Copied the resultant alfresco.war from \projects\web-client\build\dist
        to the jboss server folder \jboss-4.0.3SP1\server\default\deploy.

    4. To the folder \jboss-4.0.3SP1\server\default\conf\alfresco, copied
        the contents of the following:
            - \alfresco-src-06012006\projects\repository\config\alfresco
            - \alfresco-src-06012006\projects\web-client\config\alfresco

    5. Copied from \alfresco-src-06012006\projects\3rd-party\lib to folder
       \jboss-4.0.3SP1\server\default\deploy\jbossweb-tomcat55.sar\jsf-libs
       the following jars:
           - myfaces-api.jar
           - myfaces-impl.jar

     Again no luck :(

Regards
Akash

Outcomes