AnsweredAssumed Answered

Installing OpenOffice via Xvfb

Question asked by hikenboots on Feb 19, 2006
Latest reply on Feb 23, 2006 by simon
I installed Xvfb on Fedora Core 4 via yum install Xvfb per http://www.alfresco.org/mediawiki/index.php/Installing_on_Linux

When it starts I see sever errors as such:
Could not init font path element /usr/X11R6/lib/X11/fonts/100dpi/, removing from list!

I've been scouring google trying out whay to do next.  How do you access the gui?  Am I supposed to use a viewer of some sort?  I'm sure others have installed openoffice to a headless linux machine, please help.

Update:
I got rid of the font error by passing a font directoy parameter:
Xvfb -fp /usr/X11R6/lib/X11/fonts/misc :1 -screen 0 800x600x16 -fbdir /usr/src &

Also had to allow connections to xvfb by:
[root@home program]# xhost local:
[root@home program]# xhost +

I can get openoffice to start by dropping the -headless parameter:
[root@home program]# ./soffice "-accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager" -nologo  -display :1 &
[3] 21819
[root@home program]# ps -a
  PID TTY          TIME CMD
11787 pts/0    00:00:01 Xvfb
21819 pts/0    00:00:00 soffice
21830 pts/0    00:00:01 soffice.bin
21977 pts/0    00:00:00 ps
[root@home program]#

I still have no clue how to manipulate the program from here I've dug all around openoffoce.org and only found a bunch of circular posting with no hard answers.  Looking for a paradigm here.. I dont want to have to install X on my nice unbloated server…..

Outcomes