AnsweredAssumed Answered

[solved] Web Services Client in a tomcat application

Question asked by sam69 on Apr 4, 2006
Latest reply on Apr 5, 2006 by sam69
Hello !

I have some problems running Alfresco's webservices in a web application hosted by tomcat 5.5.15 with jdk1.5.0_06.
When I run my code in a Junit test (so not in tomcat), everything is fine, but when I run it in the webapp, I got this exception :

org.apache.xml.security.c14n.InvalidCanonicalizerException: No message with ID "signature.Canonicalizer.UnknownCanonicalizer" found in resource bundle "org/apache/xml/security/resource/xmlsecurity"
   at org.apache.xml.security.c14n.Canonicalizer.<init>(Unknown Source)
   at org.apache.xml.security.c14n.Canonicalizer.getInstance(Unknown Source)
   at org.apache.xml.security.utils.XMLUtils.outputDOM(Unknown Source)
   at org.apache.ws.axis.security.WSDoAllSender.invoke(WSDoAllSender.java:366)
   at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
   at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
   at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
   at org.apache.axis.client.AxisClient.invoke(AxisClient.java:127)
   at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
   at org.apache.axis.client.Call.invoke(Call.java:2767)
   at org.apache.axis.client.Call.invoke(Call.java:2443)
   at org.apache.axis.client.Call.invoke(Call.java:2366)
   at org.apache.axis.client.Call.invoke(Call.java:1812)
   at org.alfresco.webservice.repository.RepositoryServiceSoapBindingStub.get(RepositoryServiceSoapBindingStub.java:1099)
   at com.medial.gediweb.framework.connecteurs.specifique.alfresco.connecteursAlfresco.ConnecteurDepotGEDAlfresco.initialisation(ConnecteurDepotGEDAlfresco.java:327)
   at com.medial.gediweb.framework.connecteurs.specifique.alfresco.connecteursAlfresco.ConnecteurDepotGEDAlfresco.<init>(ConnecteurDepotGEDAlfresco.java:69)
   at org.apache.jsp.jsp.exemple.test.tests_jsp._jspService(org.apache.jsp.jsp.exemple.test.tests_jsp:419)

It's look like it use an old library, because the error message is not on the properties file. I don't know where tomcat is searching the libraries, but I put on the class path all the usefull libs.
Any ideas ?

Thanks in advance !

Regards,
Samuel

Outcomes