AnsweredAssumed Answered

OpenLDAP authentication: unable to login

Question asked by dtnsolutions on May 3, 2006
Latest reply on May 3, 2006 by andy
I have configured Alfresco Open source 1.2.1 to authenticate agains Openldap but unable to login after changing WEB-INF\classes\alfresco\authentication-services-context.xml to:

<bean id="authenticationComponentImpl" class="org.alfresco.repo.security.authentication.ldap.LDAPAuthenticationComponentImpl">
        <property name="LDAPInitialDirContextFactory">
            <ref bean="ldapInitialDirContextFactory" />
        </property>
        <property name="userNameFormat">
            <value>cn=%s,dc=mycompany,dc=com</value>
        </property>
    </bean>
   
    <bean id="ldapInitialDirContextFactory" class="org.alfresco.repo.security.authentication.ldap.LDAPInitialDirContextFactoryImpl">
        <property name="initialDirContextEnvironment">
             <map>
                <entry key="java.naming.factory.initial">
                    <value>com.sun.jndi.ldap.LdapCtxFactory</value>
                </entry>
                <entry key="java.naming.provider.url">
                    <value>ldap://192.168.0.200:389</value>
                </entry>
                <entry key="java.naming.security.authentication">
                    <value>simple</value>
                </entry>
                <entry key="java.naming.security.principal">
                    <value>cn=root,dc=mycompany,dc=com</value>
                </entry>
                <entry key="java.naming.security.credentials">
                    <value>secret</value>
                </entry>
               
             </map>
        </property>
    </bean>

I added og4j.logger.org.alfresco.repo.security.authentication.ldap=debug to log4j.properties but there's nothing in the log file when the login is failed.

Regards,
Tien Nguyen

Outcomes