AnsweredAssumed Answered

Web Services Client using JDK1.4 on WebSphere

Question asked by csbrown on May 11, 2006
Latest reply on Sep 28, 2007 by csbrown
We have a need on our project to use the Web Services Client to connect to an Alfresco server from a WebSphere Application Server 6.0.   But, WebSphere 6.0 is stuck back in JDK1.4.2.  When I initially tried to use the web services client jar in the 1.4.2 environment, it failed.

Is it the case that the Web Services Client is only supported for JDK1.5?

I ended up modifying the code for the client to be 1.4 compatible.  To make it work I also had to change the bouncy castle library to the 1.4 compatible version as well.  Beyond that everything works fine.

It seems like the web services client should be one component that should be as flexible as possible as far as JDK version goes.  Why require every client that wants to use the client to be 1.5? 

Is there any plans in the Alfresco team to keep/create a version available for older Java versions?

Thanks,

Outcomes