AnsweredAssumed Answered

J2SE 1.4 Support for JCR Clients?

Question asked by mjanson on Jun 20, 2006
Latest reply on Jun 21, 2006 by mjanson
Is there anything in the works to make the JCR API backward compatible to J2SE 1.4 (or even 1.3)?  The docs seem to suggest that 1.5 is required everywhere, and while we don't have a problem firing up a container for running the actual repository, we have a number of enterprise applications deployed to Weblogic 8 that are bound to J2SE 1.4 due to vendor support.  If Java SE 5 is required for all clients using JCR to connect to the repository, it might be a showstopper for us to move forward with Alfresco compared with other JCR document stores that support it.

Outcomes