AnsweredAssumed Answered

Alfresco 1.3RC2 on Fedora 5

Question asked by rafiton on Jun 24, 2006
Latest reply on Jun 24, 2006 by rafiton
Hi all,

I tried to install Alfresco on a Linux machine running Fedora Core 5 with its MySQL and Tomcat as follows:
1. I installed jdk-1_5_0_07-linux-i586.rpm since this distro comes with GNU Java
2. I downloaded alfresco-community-tomcat-1.3.0RC2.tar.gz
3. I unpacked the files into /opt/alfresco
4. I changed JAVA_HOME to point to the JRE
5. MySQ, Apache and Tomcat are running correctly (I get the Apache and Tomcat welcome pages on localhost and localhost:8080 respectively)

When I try to run Alfresco (./alfresco.sh start from /opt/alfresco) it returns:

[root@localhost alfresco]# ./alfresco.sh start
Using CATALINA_BASE:   /opt/alfresco/tomcat
Using CATALINA_HOME:   /opt/alfresco/tomcat
Using CATALINA_TMPDIR: /opt/alfresco/tomcat/temp
Using JRE_HOME:       /usr/java/jdk1.5.0_07
Using JAVA_OPTS:       -Xms128m -Xmx512m -server -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager -Djava.util.logging.config.file=/opt/alfresco/tomcat/conf/logging.properties

If I try to browse to http://localhost:8080/alfresco I get the Tomcat Error 404 page saying that "The requested resource (/alfresco) is not available."

I tried to change the APPSERVER statement in alfresco.sh to APPSERVER=/usr/share/tomcat5 but then I get "./alfresco.sh: line 10: /usr/share/tomcat5/bin/startup.sh: No such file or directory" when I execute "./alfresco.sh start".

I think the problem is pointing to the correct Tomcat but I have no idea how to correct it.

Please help.
Rafi Ton

Outcomes