AnsweredAssumed Answered

Oracle 10g Error:  Data size bigger than max size

Question asked by idahodeq on Jun 28, 2006
I had Alfresco 1.2.1 installed on a test machine with MySQL that had no problems at all.  Now that we are moving it to Oracle and a production machine I've ran into an error when its importing the groups from Active Directory.  I had this working on MySQL, and the users are synchronizing correctly.  Heres my error:

09:55:28,092 ERROR [org.quartz.core.ErrorLogger] Job (DEFAULT.ldapGroupJobDetail threw an exception.
org.quartz.SchedulerException: Job threw an unhandled exception. [See nested exception: org.alfresco.repo.importer.ExportSourceImporterException: Failed to import]
   at org.quartz.core.JobRunShell.run(JobRunShell.java:202)
   at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:516)
* Nested Exception (Underlying Cause) —————
org.alfresco.repo.importer.ExportSourceImporterException: Failed to import
   at org.alfresco.repo.importer.ExportSourceImporter.doImport(ExportSourceImporter.java:165)
   at org.alfresco.repo.importer.ImporterJob.execute(ImporterJob.java:36)
   at org.quartz.core.JobRunShell.run(JobRunShell.java:191)
   at org.quartz.simpl.SimpleThreadPool$WorkerThread.run(SimpleThreadPool.java:516)
Caused by: javax.transaction.RollbackException: Transaction didn't commit: Hibernate operation: could not insert collection: [org.alfresco.repo.domain.hibernate.NodeImpl.properties#component[protocol,identifier,guid]{protocol=user, guid=7d2aee80-06be-11db-b6e1-77dbf223f4c0, identifier=alfrescoUserStore}]; uncategorized SQLException for SQL [insert into node_properties (protocol, identifier, guid, qname, actual_type, multi_valued, persisted_type, boolean_value, long_value, float_value, double_value, string_value, serializable_value) values (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]; SQL state [null]; error code [17070]; Data size bigger than max size for this type: 4404; nested exception is java.sql.SQLException: Data size bigger than max size for this type: 4404
   at org.alfresco.util.transaction.SpringAwareUserTransaction.commit(SpringAwareUserTransaction.java:403)
   at org.alfresco.repo.importer.ExportSourceImporter.doImport(ExportSourceImporter.java:159)
   … 3 more
This is on Oracle 10g and I tried both OracleDialect and Oracle9Dialect just to see if it made a difference, but I end up with the same error:  Data size bigger than max size for this type: 4404.
It appears to be in conjunction with the long raw field node_properties.SERIALIZABLE_VALUE?

I really need to get this going!  This is (almost) my last issue and whether or not we use Alfresco rides on my getting this going.

Thanks!!
Nate

Outcomes