AnsweredAssumed Answered

FirstFoundationClient : authentication for admin failed

Question asked by jmliege on Jul 10, 2006
Latest reply on Jul 11, 2006 by jmliege
Hello,

I've installed the 1.3 release.
The webclient seems to work properly.I've made the tutorial, and some minor customizations so far (just started during last week…)

So I wanted to test the sample code, then I ran almost directly into some trouble…

authenticationService.authenticate("admin","admin".toCharArray());

generates the following:

Exception in thread "main" org.alfresco.repo.security.authentication.AuthenticationException: Bad credentials presented
   at org.alfresco.repo.security.authentication.AuthenticationComponentImpl.authenticate(AuthenticationComponentImpl.java:69)
   at org.alfresco.repo.security.authentication.AuthenticationServiceImpl.authenticate(AuthenticationServiceImpl.java:104)
….
….
Caused by: net.sf.acegisecurity.BadCredentialsException: Bad credentials presented
   at net.sf.acegisecurity.providers.dao.DaoAuthenticationProvider.getUserFromBackend(DaoAuthenticationProvider.java:393)
   at net.sf.acegisecurity.providers.dao.DaoAuthenticationProvider.authenticate(DaoAuthenticationProvider.java:225)
   at net.sf.acegisecurity.providers.ProviderManager.doAuthentication(ProviderManager.java:159)
   at net.sf.acegisecurity.AbstractAuthenticationManager.authenticate(AbstractAuthenticationManager.java:49)
   at org.alfresco.repo.security.authentication.AuthenticationComponentImpl.authenticate(AuthenticationComponentImpl.java:63)
   … 23 more

I've checked other functions of the AuthenticationService.

authenticationService.authenticationExists("admin")  returns false…
authenticationService.getCurrentUserName() returns "System"…

I've also tried the authenticationService.createAuthentication("admin","admin".toCharArray()), but an Exception about a not supported feature has been throwed.

So I think something should be wrong at some point in my configuration, but where ???

FYI: I also test with an user that I created myself through the web-client, but it doesn't sound better…

I've also watch for information about net.sf.acegisecurity …but I'm still without a solution.

I was thinkin about the "admin" password argument not well translated and thus, the AuthenticationManager returns a "bad credentials".

But "admin" user is not even recognized (or has not yet been authenticated) as the "authenticationExists("admin")  returns false" should imply, I'm not sure about this suggestion.

Thanks for any help that can be provided.

Best regards,
Jean-Marc

Outcomes