AnsweredAssumed Answered

Alfresco folder: name Alfresco_1.3 causes problems?

Question asked by loggheci on Jul 14, 2006
Latest reply on Jul 14, 2006 by rivetlogic
I installed Alfresco 1.3 on my XP machine with Tomcat 5.0… and MySQL.
I used the foldername Alfresco_1.3.

While starting up Alfresco with Alf_start, I could not connect to my Alfresco database…

First I got a SEVERE error, that was because in custom-db-connection.properties the db.url was set to jdbc:mysql://localhost/alfresco instead of jdbc:mysql://localhost/alfresco_1.3.

After I changed db.url to jdbc:mysql://localhost/alfresco_1.3 I got an ERROR:

12:41:52,296 ERROR [org.hibernate.util.JDBCExceptionReporter] Connections could not be acquired from the underlying database!
12:42:12,156 ERROR [org.hibernate.util.JDBCExceptionReporter] Connections could not be acquired from the underlying database!
12:42:12,156 ERROR [org.hibernate.tool.hbm2ddl.SchemaUpdate] could not get database metadata
java.sql.SQLException: Connections could not be acquired from the underlying database!
   at com.mchange.v2.sql.SqlUtils.toSQLException(SqlUtils.java:106)
   at com.mchange.v2.c3p0.impl.C3P0PooledConnectionPool.checkoutPooledConnection(C3P0PooledConnectionPool.java:352)
….

I searched on the forums, tried everything I found, but my problem existed.
Finally I renamed my folder Alfresco_1.3 tot Alfresco, I changed db.url to the default value 'alfresco', and now everything works fine…

Strange for me, but perhaps it is normal…

Can somebody give some more explanation?

Thanks,

Chris

(Excuse me for my english, I'am Dutch speaking)

Outcomes