AnsweredAssumed Answered

Customizing the repository properties

Question asked by jmliege on Jul 20, 2006
Latest reply on Jul 24, 2006 by jmliege
Hi,

I've got a strange problem.

I've added a new *-context.xml to redefine the repository-properties bean.
This one is similar to the custom-repository-context.xml.


<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>
  
    <!– overriding to point to custom properties –>
    <bean id="repository-properties" class="org.springframework.beans.factory.config.PropertyPlaceholderConfigurer">
        <property name="ignoreUnresolvablePlaceholders">
            <value>true</value>
        </property>
        <property name="locations">
            <list>
                <value>classpath:alfresco/repository.properties</value>
                <value>classpath:alfresco/version.properties</value>                         <value>classpath:alfresco/domain/transaction.properties</value>

                <!– Override repository properties –>
<value>classpath:alfresco/extension/custom-repository.properties</value>
            </list>
        </property>
    </bean> 
</beans>

Then I had this new custom-repository.properties in order to set my smtp server.


# Email configuration
mail.host=127.0.0.1
mail.port=25
mail.username=webmaster@jmb.org
mail.password=xxxxx
mail.encoding=UTF-8

After I restart the server, I can 't connect anymore (web-client and CIFS) even with admin/admin…

So, I just remove this two files, and then after another restart, I can connect…

I also tried to make a full copy of the repository.properties, but it doesn't work better…

My version is 1.3 schema 14.

JM

Outcomes