AnsweredAssumed Answered

can not get the first Alfresco sample program to work

Question asked by jameszhou on Jul 24, 2006
Latest reply on Jul 27, 2006 by dreddy
Hi this is my first time to try out the Alfresco sample, but I could not get it to work.

I first installed Alfresco ECM 1.3, and then started the Alfresco ECM. That works OK. I can login as "admin/admin", and create a bunch of contents using Web Client.  Then I wanted to try to use the APIs. So I downloaded alfresco-SDK, and followed the instruction on the wiki to install all samples in the Eclipse. But when I ran the sample FirstFoundationClient.java, there were some exceptions coming out from the console: net.sf.acegisecurity.BadCredentialsException: Bad credentials presented
   at net.sf.acegisecurity.providers.dao.DaoAuthenticationProvider.getUserFromBackend(DaoAuthenticationProvider.java:393)
   at net.sf.acegisecurity.providers.dao.DaoAuthenticationProvider.authenticate(DaoAuthenticationProvider.java:225)
   at net.sf.acegisecurity.providers.ProviderManager.doAuthentication(ProviderManager.java:159)
   at net.sf.acegisecurity.AbstractAuthenticationManager.authenticate(AbstractAuthenticationManager.java:49)
   at org.alfresco.repo.security.authentication.AuthenticationComponentImpl.authenticate(AuthenticationComponentImpl.java:63)
   … 23 more


When I ran the sample, I kept the tomcat server up.  Shall I stop the tomcat? I actaully tried, but the sample program still threw the exception.  any ideas?

Outcomes