AnsweredAssumed Answered

install on JES2005Q4 webserver: all ok except mysql part

Question asked by tvanover on Aug 22, 2006
Latest reply on Aug 23, 2006 by tvanover
Hi,

I succesfully deployed alfresco 1.3 on our JES2005Q4 test server (on the webserver, not the application server). I d'loaded and installed the mysql jdbc connector. on a separate server where mysql is running, i created the alfresco database using the db_setup.sql script and ensured that the JES server can contact the mysql server via the network.

Then I tried to startup alfresco but it complained about not being able to connect to the mysql database, so we looked a bit further and edited the file …./alfresco/WEB-INF/classes/alfresco/extension/custom-db-connection.properties

we uncommented the first four lines:

db.username=alfresco
db.password=alfresco
db.pool.initial=10
db.pool.max=100


and also:

db.driver=org.gjt.mm.mysql.Driver
db.url=jdbc:mysql://172.16.4.98/alfresco

then we restarted the webserver, but we still see this error in the webserver logs, see underneath. I guess the last line is the most interesting one.

So my question is: what did we miss ?

Thx,
Tom.


[22/Aug/2006:16:07:44] info (18326): CORE3282: stdout:  at org.apache.catalina.core.StandardEngine.start(Stand
ardEngine.java:355)
[22/Aug/2006:16:07:44] info (18326): CORE3282: stdout:  at org.apache.catalina.startup.Embedded.start(Embedded
.java:995)
[22/Aug/2006:16:07:44] info (18326): CORE3282: stdout:  at com.iplanet.ias.web.WebContainer.start(WebContainer
.java:431)
[22/Aug/2006:16:07:44] info (18326): CORE3282: stdout:  at com.iplanet.ias.web.WebContainer.startInstance(WebC
ontainer.java:500)
[22/Aug/2006:16:07:44] info (18326): CORE3282: stdout:  at com.iplanet.ias.server.J2EERunner.confPostInit(J2EE
Runner.java:161)
[22/Aug/2006:16:07:44] info (18326): CORE3282: stdout: Caused by: com.mchange.v2.resourcepool.CannotAcquireRes
ourceException: A ResourcePool could not acquire a resource from its primary factory or source.

Outcomes