AnsweredAssumed Answered

Workflow deployment failed

Question asked by alessioa. on Oct 9, 2006
Latest reply on Dec 1, 2006 by davidc
Hi to all the folks,
i have problems to deploy on Alfresco a sample workflow.
I follow these steps:
1) create the process with eclipse
2) tried to deploy the process from eclipse; it's work but after this i don't understood how link my process with the task model i created for it.
For this reason i proceeded with a manual deploy ad create this file:
<?xml version='1.0' encoding='UTF-8'?>
<!DOCTYPE beans PUBLIC '-//SPRING//DTD BEAN//EN' 'http://www.springframework.org/dtd/spring-beans.dtd'>

<beans>
   
    <bean id="extension.workflowBootstrap" parent="workflowDeployer">
          <property name="workflowDefinitions">
            <list>
               <props>
                  <prop key="engineId">jbpm</prop>
                  <prop key="location">alfresco/extension/my_workflow/processes/alessio_AdHocProcessDefinition.xml</prop>
                  <prop key="mimetype">text/xml</prop>
                  <prop key="redeploy">true</prop>
               </props>
            </list>
        </property>
        <property name="models">
            <list>
                <value>alfresco/extension/my_workflow/models/alessio_AdHocTaskModel.xml</value>
            </list>
        </property>
    </bean>
         
</beans>

3) Stopped the server and placed this file under <alfresco home directory>\tomcat\shared\classes\alfresco\extension

4) created the my_workflow directory with the sub-directories models and processes

5) placed under these directories the respective files (alessio_AdHocProcessDefinition.xml, alessio_AdHocTaskModel.xml)

6) Started the server and received the follow error:
org.alfresco.error.AlfrescoRuntimeException: Workflow deployment failed
   at org.alfresco.repo.workflow.WorkflowDeployer.deploy(WorkflowDeployer.java:217)
   at org.alfresco.repo.workflow.WorkflowDeployer.onApplicationEvent(WorkflowDeployer.java:233)
   at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:45)
   at org.springframework.context.support.AbstractApplicationContext.publishEvent(AbstractApplicationContext.java:225)
   at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:323)
   at org.springframework.web.context.support.AbstractRefreshableWebApplicationContext.refresh(AbstractRefreshableWebApplicationContext.java:134)
   at org.springframework.web.context.ContextLoader.createWebApplicationContext(ContextLoader.java:246)
   at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:184)
   at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:49)
   at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3692)

[……………………………..]

Can someone help me? What do i mistake during the deploy process?

Thank you very much
Alessio A.

Outcomes