AnsweredAssumed Answered

Custom contenttype only creatable with custom mimetypes?!

Question asked by alexr on Oct 11, 2006
Latest reply on Oct 19, 2006 by alexr
First I created a new contenttype (lets call it newDocumentType) with custom properties, constraints etc. and it works fine. I can created all kinds of documents of every standard mime-type defined in Alfresco as this newDocumentType (instead of type "Content").

Now there was a need for two additional mimetypes (Microsoft Visio and Microsoft Project).

- Stopped the Alfresco services

- I created the icon-files (16x16 and 32x32) for .vsd and .mpp and stored them in the correct folderpath.

- copied a custom file: mimetype-custom-extensions.xml to:
c:\alfresco\tomcat\webapps\WEB-INF\classes\alfresco\mimetype

-copied a custom file: custom-services-context.xml to:
c:\alfresco\tomcat\shared\classes\alfresco\extension

The customizations for adding mimetypes through these two files were made exactly conform the instructions on the Alfresco Wiki pages for Mime type customization.

- Started the Alfresco services.

So far so good.

Now I created two documents of type newDocumentType with custom properties and of the mimetypes .vsd (visio) and .mpp (project).
Everything seems ok. The files are generated and have the corresponding icons.

However..

Now I tried to add a Microsoft Word document as a newDocumentType to the repository (something that worked before), but it won't get processed.
I can only add a MS Word (or any default mimetype) as of contenttype "Content" and not as the custom type newDocumentType.

Can you please tell me what could be the problem and how to solve this.

Thanks,

Regards,

Alex

Outcomes