AnsweredAssumed Answered

Can't upgrade to Alfresco 1.4 (from 1.3)

Question asked by nricheton on Nov 8, 2006
Latest reply on Mar 12, 2007 by miguel.gil.martinez
I'm not able to upgrade my existing alfresco installation to 1.4 (Community) while keeping my current repository. I have the following problems :
(os : debian )

I tryed to do a manual upgrade usig alfresco-tomcat.tar.gz : I made a backup of my DB and data and i replaced alfresco.war.

- During the first restart, alfresco automatically updates the repository, but at least 2 patches fail with transaction roll back. I can't start Alfresco : each restart gives this error : "Not all patches could be applied").

So I changed my mind, I did an export of my repository first and tried to import it back on a clean alfresco 1.4 install.

- I got alfresco 1.4 up with a manual install and an empty database, but I was not able to login. The previous admin account (admin/admin) did not work.

I set up the ldap connection to be able to log as admin.
I converted my export.acp to 1.4 format BUT

- The unix script does not work : it uses % for vars instead of $. It looks like a bad and never tested conversion of the windows script. Nevermind, I fixed it.
- The upgrader breaks the UTF-8 encoding, and all my files containing special chars have bad names AFTER using 1-3_to_1-4.sh.

Even with bad names, I tried to do the import, but  :

- Exception : duplicate node name.  The export included duplicate entries in export.xml, which Alfresco 1.3 allowed to create in my repository (sounds like a bug). I had 2 files like this. I fixed the xml manually.

Next try :
- Exception : Failed to execute import: org.alfresco.error.AlfrescoRuntimeException: Invalid store ref: Does not contain :// ../../../../cm:move[3]/cm:Intranet_x0020/cm:_x0039_GestionProjet

I think I won't be able to check manually each ref in this xml : my export has 1.5GB full of doc/ppt/txt files.

My feeling is that the upgrade process is really buggy. The Wiki page is no help (only tells to save your database : a REALLY good advice). It may have worked better if I upgraded to 1.3.1 first, but I can't find this version on sf (like this user : http://forums.alfresco.com/viewtopic.php?t=3939)

Can anyone help me with this ? I can provide my fixed 1-3_to_1-4.sh for the alfresco team.


Nicolas

Outcomes