AnsweredAssumed Answered

MMT install failed

Question asked by roberthcole on Mar 9, 2008
Latest reply on Mar 10, 2008 by janv
I have a java error that suggests the MMT installer (alfresco-mmt-2.1.0.jar) is not working with a recent Java SDK.
The command is:

linux-uyrx:/opt/alfresco #java -jar alfresco-mmt-2.1.0.jar install alfresco-recordsmanagement-2.1.0.amp tomcat/webapps/alfresco.war

This command works on my home server with a 1 year old SDK, but at work I get:

Exception in thread "main" java.lang.UnsupportedClassVersionError: org/alfresco/repo/module/tool/ModuleManagementTool (Unsupported major.minor version
49.0)
        at java.lang.ClassLoader.defineClass0(Native Method)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
        at com.simontuffs.onejar.JarClassLoader.defineClass(JarClassLoader.java:450)
        at com.simontuffs.onejar.JarClassLoader.findClass(JarClassLoader.java:441)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
        at com.simontuffs.onejar.Boot.run(Boot.java:245)
        at com.simontuffs.onejar.Boot.main(Boot.java:105)

I installed the SDK recently, the java version is (java -version)
java version "1.4.2_11"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2
Java HotSpot(TM) Client VM (build 1.4.2_11-b06, mixed mode)

I am running alfresco 2.1 (downloaded last week).
Any help will be appreciated to let me use the records management addition.
Robert.

Outcomes