AnsweredAssumed Answered

Upgrade from 1.2 to 1.4 - problem with custom types

Question asked by denisdelangle on Nov 10, 2006
Latest reply on Nov 13, 2006 by denisdelangle
Hello,

I try to upgrade alfresco from 1.2 to 1.4 and I face problems with my customModel.
Fist of all, I ran the script on my DB to get from 1.2 to 1.3 and then I started alfresco 1.4.

I get these messages when I start Alfresco :

org.alfresco.repo.policy.PolicyException: Class definition advancedFolder does not exist.
org.alfresco.error.AlfrescoRuntimeException: Not all patches could be applied


I placed my customModel.xml declaring my advancedFolder in tomcat/shared/classes/alfresco/extensions and in tomat/webapps/alfresco/WEB-INF/classes/alfresco/extensions/

but I still get the same error message.

There is no message telling that it fails loading my customModel.xml


Here is my customModel.xml.
<!– Custom Model –>

<!– Note: This model is pre-configured to load at startup of the Repository.  So, all custom –>
<!–       types and aspects added here will automatically be registered –>

<model name="custom:customModel"
        xmlns="http://www.alfresco.org/model/dictionary/1.0">

        <!– Optional meta-data about the model –>
        <description>Custom Model</description>
        <author></author>
        <version>1.0</version>

        <imports>
                <!– Import Alfresco Dictionary Definitions –>
                <import uri="http://www.alfresco.org/model/dictionary/1.0"
                        prefix="d" />
                <!– Import Alfresco Content Domain Model Definitions –>
                <import uri="http://www.alfresco.org/model/content/1.0"
                        prefix="cm" />
        </imports>

        <!– Introduction of new namespaces defined by this model –>
        <!– NOTE: The following namespace custom.model should be changed to reflect your own namespace –>
        <namespaces>
                <namespace uri="custom.model" prefix="custom" />
                <namespace uri="my.new.model" prefix="my" />
        </namespaces>

        <types>
                <type name="custom:advancedFolder">
                        <title>Espace Avancé</title>
                        <parent>cm:folder</parent>
                        <properties>
                                <property name="custom:status">
                                        <type>d:text</type>
                                </property>
                                <property name="custom:ranking">
                                        <type>d:text</type>
                                </property>
                        </properties>
                </type>
          </types>
</model>

Anyone has an idea ? Thank's

Outcomes