AnsweredAssumed Answered

Connecting Alfresco with PHP 4

Question asked by naramski on Nov 15, 2006
I'm using alfresco for an old server with PHP4 installed.

I can't use the alfreco-php library because it's require PHP 5.

I'm trying to use the PEAR SOAP library to connect my application to the alfresco server.

I can easily get a token from the AuthenticationService, but after, I can't retransmit the SecurityHeader.

I used the addSecurityHeader function from the alfresco-php library, but I receive a stacktrace which contains: "WSDoAllReceiver: Request does not contain required Security Header …"

I don't know what to do next.

Is a solution for using alfresco Webservices with PHP 4 ?

Thanks for your help

Outcomes