AnsweredAssumed Answered

Alfresco 2.1 Community Cluster configuration

Question asked by elwood on Mar 14, 2008
Hi all,
I'm tryng to setup a cluster of two tomcat/alfresco 2.1 CE (bundle version) in the same phisical server but I have no success.
I've seen the the wiki page:
http://wiki.alfresco.com/wiki/High_Availability_Configuration_V1.4_to_V2.1
but it's not clear which is the right  Lucene Index Synchronization configuration to use for the 2.1 so I've tried the first one that was wprking on the 2.1.0R1.
Anyway once the servers are started (the second with all the ports shifted) I do not see anything in the log that tell me about peer discovery for index syncronization.
I've added in the WEB-INF/lib the backport-util-concurrent-3.0.jar (as described in another post).

I've tryed some ehcache-custom.xml configurations:

1. the default one

2.
<cacheManagerPeerProviderFactory
            class="net.sf.ehcache.distribution.RMICacheManagerPeerProviderFactory"
            properties="peerDiscovery=manual,
                        rmiUrls=//192.168.20.104:40001/default|
                                //192.168.20.104:40002/default|
                                //192.168.20.104:40001/default|
                                //192.168.20.104:40002/default"/>
sever one:

<cacheManagerPeerListenerFactory
            class="net.sf.ehcache.distribution.RMICacheManagerPeerListenerFactory"
            properties="hostName=192.168.20.104,
                        port=40001,
                        socketTimeoutMillis=5000"/>
sever two:

<cacheManagerPeerListenerFactory
            class="net.sf.ehcache.distribution.RMICacheManagerPeerListenerFactory"
            properties="hostName=192.168.20.104,
                        port=40002,
                        socketTimeoutMillis=5000"/>

can someone tell me how to setup a working configuration?
Thank you in advance,
Elwood.

Outcomes