AnsweredAssumed Answered

Custom Property and Advanced Search

Question asked by richardgundersen on Mar 17, 2008
Latest reply on Jun 17, 2009 by liao1108
Hi

I can't do an advanced search on my custom property. It all seems configured correctly, I can see the value on the details screen for one of my documents, and I can see it appearing as a new search field in the Advanced Search field.

But, when I do a search on it, I get no results found, even though I can see that one of my documents definately has a value set for this property.

Here's how my property is defined:

             <property name="ix:dataSource">
                <type>d:text</type>
                <mandatory>false</mandatory>
                <!–index enabled="true">
                   <atomic>true</atomic>
                   <stored>false</stored>
                   <tokenised>false</tokenised>
                </index–>
             </property>

(I've commented out the index tags - they didn't seem to make any difference.

This is how the search field is defined

    <config evaluator="string-compare" condition="Advanced Search">
       <advanced-search>
          <custom-properties>
             <meta-data aspect="ix:docAspect" property="ix:dataSource"/>
          </custom-properties>
       </advanced-search>
    </config>

So if my value for dataSource is set to 'SomeDataSource' I should be able to Advanced Search –> Additional options and then enter ''SomeDataSource' and it should bring back my document, right? But it doesn't…

Any help would be great - must be something simple I am doing wrong??

Outcomes