AnsweredAssumed Answered

Virtualization Server not connecting

Question asked by sbzoom on Mar 19, 2008
Latest reply on Jan 19, 2009 by komal
Hello.
I have been searching the boards and I'm sure this has been covered before but I just can't seem to find an answer.  I am pretty sure I have everything configured correctly for my virtualization server, but it never "sees" my Alfresco instance.


# alfresco-shared.properties
# Name of the host running AVM
#avm.remote.host=10.4.4.34
avm.remote.host=localhost

# AVMRemote API
avm.remote.port=50500



# alfresco-virtserver.properties
#alfresco.virtserver.domain=wcm.alloymarketing.com
alfresco.virtserver.domain=10-4-4-34.ip.alfrescodemo.net

alfresco.virtserver.cache-control.max-age.preview=4
alfresco.virtserver.cache-control.max-age.workarea=1800
alfresco.virtserver.cache-control.max-age.staging=1800
alfresco.virtserver.cache-control.max-age.default=1800

alfresco.virtserver.http.port=8180

alfresco.virtserver.jmxrmi.port=50501

alfresco.virtserver.connection.retry.interval=5000

alfresco.virtserver.cifs.avm.versiontree.win=v
alfresco.virtserver.cifs.avm.versiontree.unix=/media/alfresco/cifs/v

alfresco.virtserver.cifs.avm.versiontree.win.automount=true
alfresco.virtserver.cifs.avm.versiontree.unix.automount=true

alfresco.server.user=charvey
alfresco.server.password=myPassword



# virtual-tomcat/logs/catalina.out
Mar 19, 2008 10:57:15 AM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
INFO: The Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: /usr/l
ib/java-1.5.0/jdk1.5.0_11/jre/lib/i386/server:/usr/lib/java-1.5.0/jdk1.5.0_11/jre/lib/i386:/usr/lib/java-1.5.0/jdk1.5.0_11/jre/../lib/i386:/root/
lib
Mar 19, 2008 10:57:15 AM org.apache.coyote.http11.Http11BaseProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8180
Mar 19, 2008 10:57:15 AM org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1495 ms
Mar 19, 2008 10:57:15 AM org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
Mar 19, 2008 10:57:15 AM org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5
Mar 19, 2008 10:57:15 AM org.springframework.core.CollectionFactory <clinit>
INFO: JDK 1.4+ collections available
Mar 19, 2008 10:57:16 AM org.springframework.beans.factory.xml.XmlBeanDefinitionReader loadBeanDefinitions
INFO: Loading XML bean definitions from URL [file:/code/virtual-tomcat/conf/alfresco-virtserver-context.xml]
Mar 19, 2008 10:57:16 AM org.springframework.context.support.AbstractRefreshableApplicationContext refreshBeanFactory
INFO: Bean factory for application context [org.springframework.context.support.FileSystemXmlApplicationContext;hashCode=4536327]: org.springfram
ework.beans.factory.support.DefaultListableBeanFactory defining beans [virtserver-properties,avmReauthenticatingAdvisor,reauthenticatingAdvice,cl
ientTicketHolder,authenticationService,avmRemote,avmRemoteTransport,avmRemoteTransportRaw,attributeService,attributeServiceTransport,attributeSer
viceTransportRaw,jndiInfoBean,virtServerInfo,virtServerMBeanServer,virtServerRegistry,serverConnector,virtServerExporter,virtWebappRegistry,cache
ControlInfo]; root of BeanFactory hierarchy
Mar 19, 2008 10:57:16 AM org.springframework.context.support.AbstractApplicationContext refresh
INFO: 19 beans defined in application context [org.springframework.context.support.FileSystemXmlApplicationContext;hashCode=4536327]
Mar 19, 2008 10:57:16 AM org.springframework.core.io.support.PropertiesLoaderSupport loadProperties
INFO: Loading properties file from URL [file:/code/virtual-tomcat/conf/alfresco-shared.properties]
Mar 19, 2008 10:57:16 AM org.springframework.core.io.support.PropertiesLoaderSupport loadProperties
INFO: Loading properties file from URL [file:/code/virtual-tomcat/conf/alfresco-virtserver.properties]
Mar 19, 2008 10:57:16 AM org.springframework.context.support.AbstractApplicationContext initMessageSource
INFO: Unable to locate MessageSource with name 'messageSource': using default [org.springframework.context.support.DelegatingMessageSource@15f710
7]
Mar 19, 2008 10:57:16 AM org.springframework.context.support.AbstractApplicationContext initApplicationEventMulticaster
INFO: Unable to locate ApplicationEventMulticaster with name 'applicationEventMulticaster': using default [org.springframework.context.event.Simp
leApplicationEventMulticaster@6210fb]
Mar 19, 2008 10:57:16 AM org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
INFO: Pre-instantiating singletons in factory [org.springframework.beans.factory.support.DefaultListableBeanFactory defining beans [virtserver-pr
operties,avmReauthenticatingAdvisor,reauthenticatingAdvice,clientTicketHolder,authenticationService,avmRemote,avmRemoteTransport,avmRemoteTranspo
rtRaw,attributeService,attributeServiceTransport,attributeServiceTransportRaw,jndiInfoBean,virtServerInfo,virtServerMBeanServer,virtServerRegistr
y,serverConnector,virtServerExporter,virtWebappRegistry,cacheControlInfo]; root of BeanFactory hierarchy]
Mar 19, 2008 10:57:16 AM org.springframework.remoting.rmi.RmiClientInterceptor prepare
INFO: RMI stub [rmi://10.4.4.34:50500/authentication] is an RMI invoker
Mar 19, 2008 10:57:17 AM org.springframework.aop.framework.DefaultAopProxyFactory <clinit>
INFO: CGLIB2 not available: proxyTargetClass feature disabled
Mar 19, 2008 10:57:17 AM org.springframework.remoting.rmi.RmiClientInterceptor prepare
INFO: RMI stub [rmi://10.4.4.34:50500/avm] is an RMI invoker
Mar 19, 2008 10:57:17 AM org.springframework.remoting.rmi.RmiClientInterceptor prepare
INFO: RMI stub [rmi://10.4.4.34:50500/attributes] is an RMI invoker
Mar 19, 2008 10:57:17 AM org.springframework.remoting.rmi.RmiRegistryFactoryBean getRegistry
INFO: Looking for RMI registry at port '50501'
Mar 19, 2008 10:57:17 AM org.springframework.remoting.rmi.RmiRegistryFactoryBean getRegistry
WARNING: Could not detect RMI registry - creating new one
Mar 19, 2008 10:57:17 AM org.springframework.beans.factory.support.DefaultSingletonBeanRegistry destroySingletons
INFO: Destroying singletons in {org.springframework.beans.factory.support.DefaultListableBeanFactory defining beans [virtserver-properties,avmRea
uthenticatingAdvisor,reauthenticatingAdvice,clientTicketHolder,authenticationService,avmRemote,avmRemoteTransport,avmRemoteTransportRaw,attribute
Service,attributeServiceTransport,attributeServiceTransportRaw,jndiInfoBean,virtServerInfo,virtServerMBeanServer,virtServerRegistry,serverConnect
or,virtServerExporter,virtWebappRegistry,cacheControlInfo]; root of BeanFactory hierarchy}
Mar 19, 2008 10:57:17 AM org.springframework.remoting.rmi.RmiRegistryFactoryBean destroy
INFO: Unexporting RMI registry
Mar 19, 2008 10:57:17 AM org.alfresco.catalina.host.AVMHost sleepBeforeRetryingConnection
WARNING: Retrying connection…

( repeat 1000 times )




# alfresco-tomcat/logs/alfresco.log
10:05:05,679 WARN  [org.springframework.remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI registry - creating new one
10:05:14,958 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.alfresco.repo.domain.hibernate.dialect.AlfrescoSQLServerDialect.
10:05:19,777 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
10:05:42,578 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /data/alf_data
10:05:42,810 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
10:05:43,328 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
10:05:48,185 WARN  [org.alfresco.util.OpenOfficeConnectionTester] A connection to OpenOffice could not be established.
10:05:48,244 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_11-b03; maximum heap size 1228.813MB
10:05:48,246 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco license: Enterprise Network granted to Enterprise Network License Holder (does not expire)
10:05:48,248 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Enterprise Network): Current version 2.1.1 (193) schema 77 - Installed version 2.1.1 (177) schema 77
10:09:17,501 WARN  [org.alfresco.web.config.ClientConfigElement] Virtualisation Server not started - reverting to default IP: 127-0-0-1.ip.alfrescodemo.net
10:09:17,501 WARN  [org.alfresco.web.config.ClientConfigElement] Virtualisation Server not started - reverting to default port: 8180


So, any glaring mistakes here?  What should I be looking for or doing differently?  Thanks for the help.


Charlie

Outcomes