AnsweredAssumed Answered

TinyMCE - strip out <script> tag

Question asked by lesoft on Mar 22, 2008
Latest reply on Mar 22, 2008 by pmonks
Hi -

I am experiencing an issue when copy and paste a block of JavaScript code into a TinyMCE field. It seems that TinyMCE stripping out <script> tag.

For example, the following block of JS code get copied into HTML TinyMCE field

<div id="row3-movie1" class="sub-module-a">
   <script language="JavaScript1.1">
   <!–
      var soPromoC1 = new SWFObject("/home/07/flash/promoc.swf?promoIndex=0&anim=0", "movie", "182", "182", "8", "#232833");
      soPromoC1.addVariable('sDataLoc', sDataLoc);
      soPromoC1.addParam('allowScriptAccess', 'always');
    }
   //–>
   </script>
</div>

The render template outputs


<div id="row3-movie1" class="sub-module-a">
  <!–
  var soPromoC1 = new SWFObject("/home/07/flash/promoc.swf?promoIndex=0&anim=0", "movie", "182", "182", "8", "#232833");
  soPromoC1.addVariable('sDataLoc', sDataLoc);
  soPromoC1.addParam('allowScriptAccess', 'always');
  }
//–>
</div>

Notice that there is no <script> tag surrounding the generated code.

Here is my XSD schema

<xs:element name="html" type="xs:string">
   <xs:annotation>
       <xs:appinfo>
   <alf:label>Content</alf:label>
   <alf:appearance>full</alf:appearance>
       </xs:appinfo>
    </xs:annotation>
</xs:element>

In XSLT template I tell it to DOE as in the code below


<div id="content-main">
   <xsl:value-of select="./fox:html" disable-output-escaping="yes"/>
</div>

I hope someone can shed somelight on the issue.  Also, I found a message in TinyMCE forum that suggested to add the support tag in TinyMCE configuration file. If that is so, where is the TinyMCE configuration file in Alfresco environment.

Thanks for your time.
Tuan

Outcomes