AnsweredAssumed Answered

Memory issue when Alfresco is deployed Tomcat on W2K3

Question asked by michielwillekens on Mar 24, 2008
Dear all,

I have deployed the Alfresco 2.9.0B warfile on Tomcat 5.5.28 on a clean Windows 2003 Server. When Alfresco is successfully deployed the Kernel memory slowly increases of W2K (about 5 MB/minute) until the server crashes.

The specs of the server are:

Dell PowerEdge 2950
OS > Windows 2003 R2 STD SP2
Mem > 4 Gb RAM
CPU > 2 x Dual core 1,6 Ghz, 677 Mhz
Storage > 3 x 74 Gb RAID 1
Network > 1 Gb (Auto)

Tomcat is configured to use the following Java options:

JVM: jdk1.5\jre\bin\server\jvm.dll
Initial memory pool: 512MB Maximum memory pool: 1024MB
Configured with Native DLL tcnative-1.dll

Alfresco is configured to be working with MS SQL 2005. This database is installed on the same server.

The logs when Alfresco successfully starts on Tomcat

24-mrt-2008 13:53:00 org.apache.coyote.http11.Http11AprProtocol init
INFO: Initializing Coyote HTTP/1.1 on http-8080
24-mrt-2008 13:53:00 org.apache.coyote.ajp.AjpAprProtocol init
INFO: Initializing Coyote AJP/1.3 on ajp-8009
24-mrt-2008 13:53:00 org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 1125 ms
24-mrt-2008 13:53:00 org.apache.catalina.core.StandardService start
INFO: Starting service Catalina
24-mrt-2008 13:53:00 org.apache.catalina.core.StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.26
24-mrt-2008 13:53:00 org.apache.catalina.core.StandardHost start
INFO: XML validation disabled
24-mrt-2008 13:53:01 org.apache.catalina.startup.HostConfig deployWAR
INFO: Deploying web application archive alfresco.war
13:53:24,110 User:System WARN  [remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI registry - creating new one
13:53:28,250 User:System INFO  [domain.schema.SchemaBootstrap] Schema managed by database dialect org.alfresco.repo.domain.hibernate.dialect.AlfrescoSQLServerDialect.
13:53:29,407 User:System INFO  [domain.schema.SchemaBootstrap] No changes were made to the schema.
13:53:31,688 User:System WARN  [repo.admin.ConfigurationChecker] The Alfresco 'dir.root' property is set to a relative path './alf_data'.  'dir.root' should be overridden to point to a specific folder.
13:53:31,688 User:System INFO  [repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: .\alf_data
13:53:31,734 User:System INFO  [admin.patch.PatchExecuter] Checking for patches to apply …
13:53:32,094 User:System INFO  [repo.module.ModuleServiceImpl] Found 0 module(s).
13:53:33,859 User:System WARN  [alfresco.util.OpenOfficeConnectionTester] A connection to OpenOffice could not be established.
13:53:33,875 User:System INFO  [service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_15-b04; maximum heap size 986,125MB
13:53:33,875 User:System INFO  [service.descriptor.DescriptorService] Alfresco started (Community Network): Current version 2.9.0 (B 683) schema 116 - Installed version 2.9.0 (B 683) schema 116
24-mrt-2008 13:53:39 org.apache.coyote.http11.Http11AprProtocol start
INFO: Starting Coyote HTTP/1.1 on http-8080
24-mrt-2008 13:53:39 org.apache.coyote.ajp.AjpAprProtocol start
INFO: Starting Coyote AJP/1.3 on ajp-8009
24-mrt-2008 13:53:39 org.apache.catalina.storeconfig.StoreLoader load
INFO: Find registry server-registry.xml at classpath resource
24-mrt-2008 13:53:39 org.apache.catalina.startup.Catalina start
INFO: Server startup in 39120 ms

When Tomcat is stopped.

JProfiler> Disconnected.
24-mrt-2008 13:56:01 org.apache.catalina.core.StandardService stop
INFO: Stopping service Catalina
log4j:ERROR LogMananger.repositorySelector was null likely due to error in class reloading, using NOPLoggerRepository.
24-mrt-2008 13:56:03 org.apache.coyote.http11.Http11AprProtocol destroy
INFO: Stopping Coyote HTTP/1.1 on http-8080
24-mrt-2008 13:56:04 org.apache.coyote.ajp.AjpAprProtocol destroy
INFO: Stopping Coyote AJP/1.3 on ajp-8009

When Tomcat is supposed to stop, the CPU's are stressed to about 60% because both Tomcat5.exe and dsm_sa_datamgr32.exe (Dell OpenManage module) are both taking about 25% of CPU time for about 15 minutes. Only then, CPU returns to normal and memory use returns to normal.

Could there be a conflict between Dell OpenManage and Alfresco? I have tried to analyse the memory use of Tomcat with Jprofiler, but couldn't find any anomalies. Also have I tried different versions of Tomcat, but without success.

Outcomes