AnsweredAssumed Answered

URGENT !!! problem encountered in shutting down alfresco 1.4

Question asked by hey123 on Dec 1, 2006
Hi,
I encounter some problems while stopping alfresco 1.4 and after unsuccessfull shut down, I can not restart it.


13:25:18,968 ERROR [MainDeployer] Undeployment failed: file:/D:/alfresco/jboss/server/default/deploy/jboss-portal.sar/po
rtal-core.war/WEB-INF/portlet.xml
org.jboss.deployment.DeploymentException: This web app does not exist here; - nested throwable: (java.lang.IllegalArgume
ntException: This web app does not exist here)

In fact it exists there. also

13:25:18,968 INFO  [LayoutDeployment] done destroying layout(s), found in :  portal
13:25:18,968 INFO  [STDOUT] java.lang.IllegalStateException: repository instance has been shut down
.
.
.
13:25:18,999 ERROR [JCRCMS] Failed to unregister repository. Some locks may persist!
java.lang.NullPointerException
        at org.jboss.portal.cms.impl.jcr.JCRCMS.stopService(JCRCMS.java:509)
        at org.jboss.system.ServiceMBeanSupport.jbossInternalStop(ServiceMBeanSupport.ja

and at the end it says that

        at org.jboss.system.server.ServerImpl$ShutdownHook.shutdown(ServerImpl.java:963)
        at org.jboss.system.server.ServerImpl$ShutdownHook.run(ServerImpl.java:941)
13:25:18,999 WARN  [ServerDeployer] A setup URL is not known by the main deployer file:/D:/alfresco/jboss/server/default
/deploy/jboss-portal.sar/conf/data/default-object.xml
13:25:22,234 INFO  [Http11Protocol] Pausing Coyote HTTP/1.1 on http-0.0.0.0-8080
13:25:23,265 INFO  [Http11Protocol] Stopping Coyote HTTP/1.1 on http-0.0.0.0-8080
Shutting down
Shutdown complete
Halting VM
Press any key to continue . . .

Also after shutting down in this way, I can  not restrart it normally.
Can you help me ?

Thank you in advance.

Outcomes