AnsweredAssumed Answered

Content transformation fails with cloned VM

Question asked by norgan on Apr 2, 2008
Hello everybody,
here is what I did :
  • Install Community 2.90b with Tomcat, OpenOffice 2.3.0, MySQL 5.1 & ImageMagic on Suse Enterprise Server 10.3 SP1 in VMWare Server 1.0.4 and everything works fine

  • Test Conversions between txt, pdf, html and odt to my liking - all fine

  • copy the VM, rename VM, host, MAC, IP, /etc/hosts

  • both VMs run side by side all right, EXCEPT with the cloned one  a transformations fail
    Failed to run Actions due to error: Content conversion failed: reader: ContentAccessor[ contentUrl=store://2008/4/1/7/35/67986d31-ffad-11dc-bc95-35424bcb4313.bin, mimetype=text/plain, size=11, encoding=UTF-8, locale=en_US] writer: ContentAccessor[ contentUrl=store://2008/3/28/3/15/e0716f16-fc6c-11dc-8fa4-5b450c7a2094.bin, mimetype=application/pdf, size=0, encoding=UTF-8, locale=en_US] options: {}
  • Other Messages on alfresco start :
    10:49:24,949 WARN  [org.springframework.remoting.rmi.RmiRegistryFactoryBean] Could not detect RMI registry - creating new one
    10:49:29,020 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] Schema managed by database dialect org.hibernate.dialect.MySQLInnoDBDialect.
    10:49:31,313 INFO  [org.alfresco.repo.domain.schema.SchemaBootstrap] No changes were made to the schema.
    10:49:33,938 INFO  [org.alfresco.repo.admin.ConfigurationChecker] The Alfresco root data directory ('dir.root') is: /opt/alfresco/alf_data
    10:49:34,147 INFO  [org.alfresco.repo.admin.patch.PatchExecuter] Checking for patches to apply …
    10:49:34,390 INFO  [org.alfresco.repo.module.ModuleServiceImpl] Found 0 module(s).
    10:49:39,628 ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
    10:49:39,629 ERROR [org.alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
    10:49:39,742 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - v1.5.0_15-b04; maximum heap size 63.563MB
    10:49:39,742 WARN  [org.alfresco.service.descriptor.DescriptorService] Alfresco JVM - WARNING - maximum heap size 63.563MB is less than recommended 512MB
    10:49:39,743 INFO  [org.alfresco.service.descriptor.DescriptorService] Alfresco started (Community Network): Current version 2.1.0 (484) schema 64 - Installed version 2.1.0 (484) schema 64

  • Dump VM2 mysql > alf_data\dump.sql

  • zip up alf_data from VM2

  • clone VM1 -> VM3 again, renaming etc.

  • Test Conversions between txt, pdf, html and odt to my liking - all fine on NEW clone !

  • shutdown alfresco and rm alf_data\*  + drop database

  • unzip alf_data of VM2 and restore dump.sql

  • restart alfreso and all is there and working but NO conversions - same error again.
So this could not be a network resolving problem, since the clone worked, until I restored the data files & db.

Any ideas ?

Clueless in Cologne (Norgan)

Outcomes