AnsweredAssumed Answered

Alfresco and Samba - Could not connect to CIFS.

Question asked by jdkrueger on Dec 14, 2006
Latest reply on Jan 13, 2009 by meansartin14
We installed Alfresco 1.4 on SuSE 10.1. We cannot connect to CIFS. The maschine is our PDC (via Samba and OpenLDAP), too. Samba und Alfresco should use different IPs. I looks like Samba and Alfresco do not work together, because Alfresco does not accept the configuration and binds itself on the wrong IP. Alfresco is not configured with LDAP, yet.

When we try to connect to CIFS via Windows 2003, we always get "wrong username or password" from Windows - and he wants us to use the domain for login, which is not used by alfresco, yet. So the login failes.

The error messages in logfiles we get are

21:09:54,188 ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgroup name, using default of WORKGROUP
21:09:54,188 ERROR [org.alfresco.smb.protocol] (This may be due to firewall settings or incorrect <broadcast> setting)
21:09:54,221 ERROR [org.alfresco.smb.protocol.netbios] NetBIOSNameServer setup error:
java.net.BindException: Address already in use
21:37:14,358 ERROR [org.alfresco.smb.protocol.mailslot] HostAnnouncer error
java.net.BindException: Address already in use


The file-servers.xml in /WEB-INF/classes/alfresco contains:

<config evaluator="string-compare" condition="CIFS Server">
      <host name="${localname}_A"/>
      <comment>Alfresco CIFS Server</comment>
      <bindto>10.122.144.1</bindto>
      <!– Set to the broadcast mask for the subnet –>
      <broadcast>255.255.0.0</broadcast>

      <!– Use Java socket based NetBIOS over TCP/IP and native SMB on linux –>
      <tcpipSMB platforms="linux,solaris,macosx"/>
      <netBIOSSMB bindto="10.122.144.1" platforms="linux,solaris,macosx"/>
      <hostAnnounce interval="5"/>

      <!– Use Win32 NetBIOS interface on Windows –>
      <Win32NetBIOS/>
      <Win32Announce interval="5"/>


      <WINS>
         <primary>10.122.133.1</primary>
         <!– <secondary>5.6.7.8</secondary> –>
      </WINS>

      <sessionDebug flags="Negotiate,Socket"/>
   </config>


Any idea how to fix this?

Regards,
Dennis

Outcomes