AnsweredAssumed Answered

Special chars not displaying properly in preview

Question asked by rmills on Apr 29, 2008
Latest reply on May 1, 2012 by anik
When creating or editing a piece of xml content in a web form, I'm able to create special characters (specifically M-dashes), that display correctly in the web form.  The web form creates an HTML rendition of the content.  When opening either the XML or HTML piece of content (clicking on their names), the special characters are displayed correctly.  However, when trying to view the HTML rendition through the preview instance, the characters are displayed incorrectly (i.e. — for an M-dash). 

Upon further examination, the page info for the HTML when opened by clicking on the file name is stated as being rendered as a UTF-8 document.  But the page info for the same HTML content being viewed through the preview instance is being rendered as ASCII ISO-8859-1.  I suspect this translation is causing the issue.  

I've tried editing the HTML behind the content in the webform (I enabled the HTML editor in TinyMCE) and replacing my special characters with their Unicode and ASCII codes (i.e. — or — or — for an M-dash) to no avail.  I had the same outcome.  The special characters displayed correctly in the web form and when opening the document (clicking its name) but NOT when previewing the document. 

Is there some way I can configure the preview instance to render content in UTF-8?  Is there another work around?

Outcomes