AnsweredAssumed Answered

Importing groups

Question asked by rguinko on May 6, 2008
Latest reply on Jun 26, 2008 by alcibiade
Hi!
I am trying to import a group to Alfresco by using bootstrap. Here are my files :
group.xml
<?xml version="1.0" encoding="UTF-8"?>
  <view:view xmlns:view="http://www.alfresco.org/view/repository/1.0"
          xmlns:cm="http://www.alfresco.org/model/content/1.0"
          xmlns:sys="http://www.alfresco.org/model/system/1.0"
          xmlns:usr="http://www.alfresco.org/model/user/1.0"
          xmlns:app="http://www.alfresco.org/model/application/1.0">
    
     <usr:authorityContainer view:childName="usr:GROUP_RG">
       <view:aspects>
         <sys:referenceable></sys:referenceable>
       </view:aspects>
       <view:properties>
         <sys:store-protocol>user</sys:store-protocol>
         <cm:name>GROUP_RG</cm:name>
         <sys:node-uuid>GROUP_RG</sys:node-uuid>
         <usr:authorityName>GROUP_RG</usr:authorityName>
         <sys:store-identifier>alfrescoUserStore</sys:store-identifier>
       </view:properties>
       <view:associations></view:associations>
     </usr:authorityContainer>

  </view:view>

group-context.xml
<bean id="_RG_bootstrapGroups" class="org.alfresco.repo.module.ImporterModuleComponent" parent="module.baseComponent">
       <property name="moduleId" value="_RG" />
       <property name="name" value="_RG_Import" />
       <property name="description" value="This module will import _RG group" />
       <property name="sinceVersion" value="1.0" />       
       <property name="appliesFromVersion" value="1.0" /> 
       <property name="importer" ref="userBootstrap"/>
       <property name="bootstrapViews">
           <list>
               <props>
                   <prop key="path">/${alfresco_user_store.system_container.childname}/sys:authorities</prop>
                   <prop key="location">alfresco/module/_RG/group.xml</prop>
               </props>
           </list>
       </property>
   </bean>

group and group-context.xml are contained in my amp file. When I update my war and launc alfresco I get a lot of errors…
Hope someone could help me solve this problem.
Thank you.

Outcomes