AnsweredAssumed Answered

Can't delete user sandbox, can't fix permissions

Question asked by ftoth on May 6, 2008
Latest reply on Feb 25, 2009 by deepakb
Hi all,

I have run into problems trying to manipulate web project users on
2.1 community. It went this way:

My user could not update items in his sandbox (no edit or update icons).
I tried to "re-invite" him, making sure to set him up as a content manager,
but no luck. There were no changes to his sandbox permissions. I tried
this several times, with and without restarts.

Then I tried "delete sandbox" and I got a "ConcurrentModificationException" failure.
I restarted several times, so admin was the only user. But still the same error.
I was unable to delete his sandbox.

Then, for a test, I added a new user, invited the test user to the web project
as content manager. That worked fine. I then deleted the test user and the
test user's sandbox. That also worked fine.

Then, my ORIGINAL user's permissions were somehow correct. He had edit
and update permissions.

Just to be thorough, I tried once again to delete his sandbox but got the
same error.

So in the end I got where I needed to be, but it was ugly and I'm concerned
now that I don't really know how to solve this in the future. Has anyone
else seen these sorts of problems? Are there any fixes or work-arounds
or tips or tricks?

Many thanks,

Fred

Outcomes