AnsweredAssumed Answered

Please help with Lucene Search...

Question asked by gianluca on Feb 27, 2007
Latest reply on Jan 28, 2008 by andy
Hi All,

I have modified the contentModel.xml for adding two new properties:


      <type name="cm:content">
         <title>Content</title>
         <parent>cm:cmobject</parent>
         <archive>true</archive>
         <properties>
            <property name="cm:content">
               <type>d:content</type>
               <mandatory>false</mandatory>
               <!— Index content in the background –>
               <index enabled="true">
                  <atomic>true</atomic>
                  <stored>false</stored>
                  <tokenised>true</tokenised>
               </index>
            </property>
            <property name="cm:www">
              <title>www</title>
              <type>d:text</type>
              <protected>true</protected>
            </property>
            <property name="cm:yyy">
              <title>yyy</title>
              <type>d:text</type>
              <protected>true</protected>
            </property>
         </properties>
         <mandatory-aspects>
           <aspect>cm:versionable</aspect>
        </mandatory-aspects>
      </type>

but if I try to search with Lucene in this two new properties I have this problem: for the first (www) I find some result correctly, for the second (yyy) any result!
(I'm sure that the phrase I'm searching EXIST!!)

I use a search code as this:


TEXT:"aaa bbb" OR @cm\:www:"aaa bbb"

There is a limit for the number of indexed properties?

Many Thanks

Outcomes