AnsweredAssumed Answered

Alfresco 2.0 + CIFS in a standalone computer

Question asked by melkor.kp on Mar 1, 2007
Latest reply on Mar 5, 2007 by melkor.kp
I am a newbe, I just managed to install alfresco under ubuntu

I was trying to configure CIFS in a Xubuntu 6.10.
Well, precisely is a windows xp running vmware.

When I started alfresco 2.0 with the CIFS support I get the following errors
in the /opt/Alfresco/alfresco.log.

ERROR [org.alfresco.smb.protocol] Failed to get local domain/workgr
oup name, using default of WORKGROUP

ERROR [org.alfresco.smb.protocol] (This may be due to firewall sett
ings or incorrect <broadcast> setting)

The computer is called workdesk it appears in the prompt user@workdesk
but there is no any dns configured, and I am not using any WINS server.

This is my file file-servers.xml
<alfresco-config area="file-servers">

   <config evaluator="string-compare" condition="CIFS Server">
          <serverEnable enabled="true"/>
      <host name="${localname}_A"/>
      <comment>Alfresco CIFS Server</comment>

      <!– Set to the broadcast mask for the subnet –>
      <broadcast>192.168.255.255</broadcast>

      <!– Use Java socket based NetBIOS over TCP/IP and native SMB on linux –>
      <tcpipSMB platforms="linux,solaris,macosx"/>
      <netBIOSSMB platforms="linux,solaris,macosx"/>

           <!– Can be mapped to non-privileged ports, then use firewall rules t
o forward
                    requests from the standard ports –>
                  
      <tcpipSMB port="1445" platforms="linux,solaris,macosx"/>
      <netBIOSSMB sessionPort="1139" namePort="1137" datagramPort="1138" platfor
ms="linux,solaris,macosx"/>
           <hostAnnounce interval="5"/>

      <!– Use Win32 NetBIOS interface on Windows –>
      <Win32NetBIOS/>
      <Win32Announce interval="5"/>

      <sessionDebug flags="Negotiate,Socket"/>
   </config>   <config evaluator="string-compare" condition="FTP Server">
          <serverEnable enabled="true"/>
   </config>
  
   <config evaluator="string-compare" condition="NFS Server">
          <serverEnable enabled="false"/>
   </config>
       
   <config evaluator="string-compare" condition="Filesystems">
          <filesystems>
                 
                 <!– Alfresco repository access shared filesystem –>
         <filesystem name="Alfresco">
            <store>workspace://SpacesStore</store>
            <rootPath>/app:company_home</rootPath>

                        <!– Add a URL file to each folder that links back to th
e web client –>
                        <urlFile>
               <filename>__AlfrescoClient.url</filename>
               <webpath>http://${localname}:8080/alfresco/</webpath>
            </urlFile>
   <!– Mark locked files as offline –>
                    <offlineFiles/>

       </filesystem>

                 <!– AVM virtualization view of all stores/versions for WCM –>
         <avmfilesystem name="AVM">
            <virtualView/>
         </avmfilesystem>

      </filesystems>
   </config>

   <config evaluator="string-compare" condition="Filesystem Security">
      <authenticator type="enterprise">
      </authenticator>
</config>


</alfresco-config>
                   
Does anybody know what is happening?

Outcomes