AnsweredAssumed Answered

NONE of my Alfresco 1.4 customizations work in 2.0!

Question asked by alexr on Mar 6, 2007
Latest reply on Mar 15, 2007 by steve
I have posted several request on this forum now, asking why my 1.4
(webclient) customizations don't work in 2.0.

Even the following addition (to make all content versionable) to the contentModel.xml file:

<mandatory-aspects>
   <aspect>cm:versionable</aspect>
</mandatory-aspects>

Doesn't work in 2.0 although it works fine in 1.4

Adding custom mime-types and custom contentmodel doesn't work either in 2.0 the way it worked in 1.4
Furthermore adding the contentmodel as defined for 1.4 throws the following error in 2.0:

Please correct the errors below then click OK.
<<<<<<<<<<<
    * A system error happened during the operation: Transaction didn't commit: Integrity failure
>>>>>>>>>>>

The only advise I got on the mime-type extension post was to check the WiKi. Which I did, but found nothing different then what I already knew and tried.

I cleared the Tomcat work directory for Alfresco and removed the Webapps entry for Alfresco then restarted Tomcat. But no effect!

I checked all the documents of Alfresco, but see no change to the way I implemented those customizations.

Is there a 1.4 to 2.0 migration document which explains what the differences in customization are.

Please help (desperate cry),

Kind regards,

Alex

Outcomes