AnsweredAssumed Answered

Migrating from 1.4 community to 2.0 using bootstrap import

Question asked by jeromebrock on Mar 9, 2007
Latest reply on Mar 9, 2007 by jeromebrock
Hi All,

First post here, sorry if it's a little lengthy, but I wanted to give some background, also this may be helpful to noobs… 

I've been evaluating 1.4 for a few months now and I wanted to get a clean start and migrate my data over to 2.0 community. In the process I wanted to optimize my system a little, so I started from scratch with building the server.

I'm running VMware on CentOS, which is just spectacular for testing and building servers, but that's another topic.  So, because CentOS is based on RHEL, which is nearly the enterprise standard linux, I chose it as my base OS for Alfresco.  Installed CentOS 4.4 server (from the single, minimal server ISO).  A side note on this, I thought it'd be nice for my Alfresco VM to have a separate disk mounted at /opt/alfresco for the data, so if I need to expand the ISO later, it would be a little easier.  For alfresco installer, you need X11 of some form, but the CentOS Gnome/KDE installers don't install a functioning environment (guess not too many people install CentOS with the GUI), so I installed with the "minimal" option then ran "# yum groupinstall "GNOME Desktop Environment"" and upon completion issued "# xinit /usr/bin/gnome-session".  This installs a working Gnome environment, which is then capable of running the Alfresco 2.0 installer.  Before running the Alfresco installer, I ran "# yum update" to get all the CentOS patches.

Ok, so I've got a clean minimal CentOS with a separate 20GB partition mounted at /opt/alfresco (just testing things here, so why waste the space), a functioning GUI and up-to-date patches.

Now to get a decent DB backend, I grab the MySQL5 RHEL4 RPM packages for the server, client and dependencies.  All is well with MySQL.

Install Alfresco2 with selecting MySQL (oddly it still puts a bunch of HSQL stuff in the filesystem).  Remove the HSQL files, run db_setup.bat, take a snapshot of my VMware machine, then "/opt/alfresco/alf_start.sh".  everything comes up fine.

Ok, now I revert back to my snapshot, so I have an un-populated MySQL db and an empty repository.  I go to my Alf1.4 server and do an Export of the complete repository, including children.  I take the 6 files, move them into the /alfresco/extension/restore folder, change them to lowercase export_spaces.acp, export_users.acp etc (looking at the restore-context.xml file, it calls them in lowercase, so just to be safe). then on all the files i chown root, chgrp root, chmod 755.  i then run "# cp restore-context.xml.sample restore-context.xml".

Ok, at this point it looks like everything is good to go.  I "# /opt/alfresco/alf_start.sh" and wait about 15 minutes for the java process to churn.  when the churning is done, http://localhost:8080/alfresco returns a broken tomcat error page.

I tried this several ways, dropped the MySQL tables deleted alf_data and re-tried editing the restore-context.xml to only pull in the users (which is mostly what I'm trying to suck out of the 1.4), etc etc etc.  After about a dozen attempts anytime I try to bootstrap any data from 1.4 it kills the server.

Any advice would be much appreciated.

Also, if anybody has any questions about my CentOS or VMware setup, I am in the process of blogging the whole procedure with great detail, so I can post a link when done.

Thanks,

-jb

Outcomes