AnsweredAssumed Answered

CIFS Enterprise -  Auth component does not support MD4

Question asked by unknown-user on Mar 16, 2007
Latest reply on Sep 12, 2007 by andy
Alfresco 2.0, Java 1.6.0, Tomcat 1.2.20, RHEL ES4U4
JAAS Repository Auth
LDAP sync (DIGEST-MD5)
CIFS FileSystem security enabled with ENTERPRISE

kinit/klist return successful certificates for the created keytab.

14:32:01,845 DEBUG [org.alfresco.smb.protocol] Waiting for TCP-SMB session request …
14:32:03,187 DEBUG [org.alfresco.smb.protocol] Server session started
14:32:03,193 DEBUG [org.alfresco.smb.protocol] Negotiated SMB dialect - NT LM 0.12
14:32:03,221 DEBUG [org.alfresco.smb.protocol] Assigned protocol handler - org.alfresco.filesys.smb.server.NTProtocolHandler
14:32:03,223 DEBUG [org.alfresco.smb.protocol] State changed to SMBSESSSETUP
14:32:06,261 DEBUG [org.alfresco.smb.protocol.auth] NT Session setup SPNEGO, MID=2, UID=0, PID=27542
14:32:06,310 DEBUG [org.alfresco.smb.protocol.auth] User  logged on  (type Normal)
14:32:06,394 DEBUG [org.alfresco.smb.protocol.auth] NT Session setup SPNEGO, MID=3, UID=0, PID=27542
14:32:06,397 WARN  [org.alfresco.smb.protocol.auth] Authentication component does not support MD4 password hashes
14:32:06,477 DEBUG [org.alfresco.smb.protocol] ## Session closing - Remote disconnect
14:32:06,478 DEBUG [org.alfresco.smb.protocol] State changed to NBHANGUP
14:32:06,478 DEBUG [org.alfresco.smb.protocol] Cleanup session, vcircuits=0, changeNotify=0
14:32:06,478 DEBUG [org.alfresco.smb.protocol] Server session closed

      
      <authenticator type="enterprise">
        <KDC>ACTIVE_DIR_SERVER</KDC>
        <Realm>COMPANY.COM</Realm>
        <LoginEntry>AlfrescoAD</LoginEntry>
        <Password>..password..</Password>
      </authenticator>

Any clues suggestions most appreciated!

Note: passthru 'works' BUT doesn't allow a CIFS auth/connection unless the user has previously authenticated to the repository via the web gui… http://forums.alfresco.com/viewtopic.php?p=18350#18350

Outcomes