AnsweredAssumed Answered

Ldap confguration issues

Question asked by dasjlm on Mar 26, 2007
Latest reply on Sep 16, 2007 by daliakamal2005
Sorry to be a pest but I have reviewed the doc/various hits etc, but still can't get ldap authentication to work.  (I'm ignoring the user/group sync aspect at this point.)


I'm testing the lastest Enterpise release and can't either our Sun Directory or Active Directory to work for web authentication.  To complicate matters I can't seem to find the trick wiht the log4j.properties to put out some kind of authentication error. How do you turn on authentcaton logging for the web client?

I suspect the problem with the Sun Directory is that it doesn't support DIGEST-MD5 as it's still using Unix CRYPT. Can't seem to find anyway to do that.  Is Unix CRYPT supported?  Do you have any other users talking to a Sun Directory Server (Netscape) using unix crypt for passwords? Can you suggest any other encyrption protocols to try?

I also tried to get authentication to work with ActiveDirectory, but still get same results.  Lognon rejected, no messages in logs. Our Active Directory is suppose to support DIGEST-MD5.

I did confirm my xp pc can communicate with both directories.
ie: Able to read the directory. 

Seems anytime I save a ldap-authentication-content.xml file the the extension directory causes authentication to break.


I assume I need to have a defined user in Alfresco to match the ldap user as no user sync for now.  Is that correct? 

ie: If my cn is dasjlm do I create an id in Alfreso to match?

What credentials to I need to use to logon to the web client?
ie: I assume I should use my cn and password?



What can I do to debug the problem as I need to resolve to do a demo of project?





:cry:

Outcomes