AnsweredAssumed Answered

Thumbnail plugin and memory problems

Question asked by theirish81 on Jun 27, 2008
Good day everyone,
I hope this is the right board for this question…
anyway, I just installed alfresco 2.1 on tomcat 5 and Mysql. Everything ran smooth, but when I installed the thumbnail plugin and added the action to make images thumbnails to a folder, here what I got:

Caused by: org.alfresco.service.cmr.repository.ContentIOException: Failed to perform ImageMagick transformation:
Execution result:
os:         Linux
command:    /usr/bin/convert /opt/tomcat/temp/Alfresco/ImageMagickContentTransformer_source_3324.jpg -resize 80 /opt/tomcat/temp/Alfresco/ImageMagickContentTransformer_target_3325.jpg
succeeded:  false
exit code:  1
out:
err:        java.io.IOException: Cannot allocate memory
at org.alfresco.repo.content.transform.magick.ImageMagickContentTransformer.transformInternal(ImageMagickContentTransformer.java:110)
at org.alfresco.repo.content.transform.magick.AbstractImageMagickContentTransformer.transformInternal(AbstractImageMagickContentTransformer.java:224)
at org.alfresco.repo.content.transform.AbstractContentTransformer.transform(AbstractContentTransformer.java:246)
… 75 more
Now, I thought it could have been a memory problem and I stretched heap and perm to the max… still no good.
Also, I tried to run the command on the command line and in ran smoothly…
Any suggestion?
Thanks in advance

Simone Pezzano

Outcomes