AnsweredAssumed Answered

Error Managing Groups

Question asked by parlocchio on Apr 12, 2007
Latest reply on Sep 17, 2007 by andy
Hi all

I've a problem with both ALFRESCO community ver.2.0 and 2.1 ( dev ).

My environment is : clean installation ( no migration from previous ALFRESCO 1.X ) on MAC OS X with Tomcat as Application Server and PostgreSQL as DB.

I have tried to create a new space named Centri and all it's ok.
I have created a new user named parlocchio.pirlocchio and all it's ok.
I have created a new group named COMMERCIALE and all it's ok.
I have added the user parlocchio.pirlocchio  to the group named COMMERCIALE and all it's ok.

Then I have assigned to the new space Centri this permission with the 'Manage Space Users' function:

- uncheck 'Inherit Parent Space Permissions' options
- Invite Group  COMMERCIALE with Consumer role

So I have tried to logout and relogin with parlocchio.pirlocchio user but I haven't access to the space Centri.
If I try to change the permission adding directly the user ( and not the Group ) with Consumer role all works fine.

Nothing changes if I modify role, space name or user/group name. The only way to access this space as GROUP is to indicate EVERYONE group.

I have tougth that the problem is similar to http://forums.alfresco.com/viewtopic.php?t=5545 but following the instructions indicated nothing changes.

With version 1.3.1 and 1.4 of Alfresco this problems is not present and all GROUPS permissions works perfectly.

Any Help is very appreciated.

:?

Outcomes