AnsweredAssumed Answered

[2.2] Connect weblogic 9.2 ldap embedded

Question asked by ribz33 on Jul 31, 2008
Latest reply on Aug 11, 2008 by ribz33
Hi,

i'm trying to connect to embedded ldap of weblogic 9.2 and i have no success
I success to connect ldap server with ldapbrowser :
I follow this tuto : http://e-docs.bea.com/wls/docs92/secmanage/ldap.html#wp1102168

After i tried to configure alfresco but i have this error :
org.alfresco.repo.security.authentication.AuthenticationException: Unable to connect to LDAP Server; check LDAP configuration

Caused by: javax.naming.CommunicationException: localhost:7001 [Root exception is java.net.ConnectException: Connection refused: connect]

Caused by: java.net.ConnectException: Connection refused: connect

My ldap properties is :
ldap.authentication.userNameFormat=%s

# The LDAP context factory to use
ldap.authentication.java.naming.factory.initial=com.sun.jndi.ldap.LdapCtxFactory

# The URL to connect to the LDAP server
ldap.authentication.java.naming.provider.url=ldap://localhost:7001/dc=alfresco_domain

# The authentication mechanism to use
ldap.authentication.java.naming.security.authentication=DIGEST-MD5

# The default principal to use (only used for LDAP sync)
ldap.authentication.java.naming.security.principal=cn=Admin

# The password for the default principal (only used for LDAP sync)
ldap.authentication.java.naming.security.credentials=weblogic

i tried also :
ldap.authentication.java.naming.provider.url=ldap://localhost:7001
But it's not working also.

Do you have an idea what is wrong ?

On ldapbrowser, i configure basedn : dc=alfesco_domain, but there is no way to configure it on Alfresco. It seems the only difference between ldapbrowser and alfresco configuration.

Thanks in advance.

Outcomes