AnsweredAssumed Answered

Error in filesystem configuration

Question asked by jgarcia on Apr 30, 2007
Latest reply on May 2, 2007 by gary.spencer
I have a configuration issue with Alfresco 1.4.0, I changed the filesystem configuration in file-servers-custom.xml file but Alfresco is not overriding the defaults.

I changed: filesystem name (from Alfresco to Personalsoft) and url link for web client (listening port is 8081 and application name is personalsoft  -alfresco.war renamed to personalsoft.war-). This is my file-servers-custom.xml file.


<alfresco-config area="file-servers">

    <config evaluator="string-compare" condition="Filesystems" replace="true">
      <filesystems>

         <filesystem name="Personalsoft">
            <store>workspace://SpacesStore</store>
            <rootPath>/app:company_home</rootPath>

            <!– Add a URL file to each folder that links back to the web client –>
            <urlFile>
               <filename>__Alfresco.url</filename>
               <webpath>http://${localname}:8081/personalsoft/</webpath>
            </urlFile>

            <!– Mark locked files as offline –>
            <offlineFiles/>

            <!– Desktop actions –>
         </filesystem>
      </filesystems>
   </config>

   <!– Allow guest access to file systems –>
   <config evaluator="string-compare" condition="Filesystem Security">
      <authenticator type="alfresco">
      </authenticator>
   </config>
</alfresco-config>

When I try to access to  \\myserver_a\Personalsoft  I get an error saying that it can't find that address.
When I try to access to  \\myserver_a\Alfresco  there was no problem at all but the url link points to http://myserver:8080/alfresco/  not to  http://myserver:8081/personalsoft/ as it should be.

Also, I tried modifiying file-servers.xml inside alfresco.war (personalsoft.war to me) but when I tried to access \\myserver_a I get this message: "You were not connected because a duplicate name exists on the network. Go to System in Control Panel to change the computer name and try again.".

Why Alfresco isn't taking my custom configuration??. Any suggestion, any idea are well recieved.
Thanks in advance,
________________________________
Juan C. Garcia
Caracas, Venezuela

Outcomes